summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-10 12:18:47 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-10 12:40:46 +0100
commita524156b1db851e3039739555578ed84a01c25a7 (patch)
tree59a2a1c2f14c835223abcd8690d4f1f1487f6ebb /x11-plugins
parentdev-util/cvise: Keyword 2.7.0 arm, #900701 (diff)
downloadgentoo-a524156b1db851e3039739555578ed84a01c25a7.tar.gz
gentoo-a524156b1db851e3039739555578ed84a01c25a7.tar.bz2
gentoo-a524156b1db851e3039739555578ed84a01c25a7.zip
x11-plugins/wmwifi: fix implicit function declarations in configure
Closes: https://bugs.gentoo.org/899062 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild b/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild
index a52c89a719bf..255ed5e11010 100644
--- a/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild
+++ b/x11-plugins/wmwifi/wmwifi-0.6-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="wireless network interface monitor dockapp"
HOMEPAGE="https://www.dockapps.net/wmwifi"
SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
@@ -19,6 +21,11 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_compile() {
# by default it does not honour our CFLAGS
emake CFLAGS="${CFLAGS}" CPPFLAGS="${CFLAGS}"