summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-24 20:43:02 +0200
committerDavid Seifert <soap@gentoo.org>2018-07-26 05:43:38 +0200
commitbca07d8f820858faa9e0b4e74932fcb51c5c5101 (patch)
tree0d9283e2c95d0536297c1e427bdafa0bfd66adf2 /x11-plugins/wmxkb
parentx11-plugins/wmwork: EAPI7, improve ebuild (diff)
downloadgentoo-bca07d8f820858faa9e0b4e74932fcb51c5c5101.tar.gz
gentoo-bca07d8f820858faa9e0b4e74932fcb51c5c5101.tar.bz2
gentoo-bca07d8f820858faa9e0b4e74932fcb51c5c5101.zip
x11-plugins/wmxkb: EAPI7, improve ebuild
Diffstat (limited to 'x11-plugins/wmxkb')
-rw-r--r--x11-plugins/wmxkb/wmxkb-1.2.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/wmxkb/wmxkb-1.2.2-r1.ebuild b/x11-plugins/wmxkb/wmxkb-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..c1686dffe7d5
--- /dev/null
+++ b/x11-plugins/wmxkb/wmxkb-1.2.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockable keyboard layout switcher for Window Maker"
+HOMEPAGE="http://wmalms.tripod.com/#WMXKB"
+SRC_URI="http://wmalms.tripod.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( CHANGES README )
+HTML_DOCS=( doc/manual{,_body,_title}.html )
+
+src_prepare() {
+ default
+ sed -i -e 's:$(LD) -o:$(CC) $(LDFLAGS) -o:' Makefile.in || die #336528
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wmxkb
+ insinto /usr/share/pixmaps/wmxkb
+ doins pixmaps/*.xpm
+ einstalldocs
+}