summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-06 21:44:18 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-06 21:44:18 -0400
commit05a1b0972b7d1a395cf58201f921dc0d4cf8fb75 (patch)
tree12357305aba12ae9573a197cbaf64722c06731fc /x11-plugins/gkrellm-xkb/files
parentx11-plugins/gkrellm-countdown: new revision fixing HOMEPAGE and LDFLAGS. (diff)
downloadgentoo-05a1b0972b7d1a395cf58201f921dc0d4cf8fb75.tar.gz
gentoo-05a1b0972b7d1a395cf58201f921dc0d4cf8fb75.tar.bz2
gentoo-05a1b0972b7d1a395cf58201f921dc0d4cf8fb75.zip
x11-plugins/gkrellm-xkb: new revision fixing CFLAGS/LDFLAGS.
This new revision is thanks to Michael Mair-Keimberger who patched three bugs at once. He made the build system respect CFLAGS and LDFLAGS, and updated the ebuild to use USE dependencies rather than just crashing if gkrellm was built without X support. Gentoo-Bug: 338786 Gentoo-Bug: 421723 Gentoo-Bug: 428388 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/gkrellm-xkb/files')
-rw-r--r--x11-plugins/gkrellm-xkb/files/gkrellm-xkb-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-xkb/files/gkrellm-xkb-makefile.patch b/x11-plugins/gkrellm-xkb/files/gkrellm-xkb-makefile.patch
new file mode 100644
index 000000000000..425a0a0417ee
--- /dev/null
+++ b/x11-plugins/gkrellm-xkb/files/gkrellm-xkb-makefile.patch
@@ -0,0 +1,35 @@
+This patch is by Michael Mair-Keimberger, as part of bug 338786. It
+teaches the Makefile to support the user's LDFLAGS.
+
+Gentoo-Bug: 338786
+
+--- a/Makefile 2004-01-05 07:34:36.000000000 +0100
++++ b/Makefile 2013-03-15 22:11:58.105227982 +0100
+@@ -5,18 +5,16 @@
+ GKRELLM_INCLUDE = -I$(PREFIX)/include
+ GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
+ GTK_LIB = `$(GTK_CONFIG) --libs`
+-FLAGS = -Wall -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+-CFLAGS ?= -O -g
+-CFLAGS += $(FLAGS)
++FLAGS = -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+-CC ?= gcc
++CC = $(CC)
+ INSTALL = install -c
+ INSTALL_PROGRAM = $(INSTALL) -s
+ PIX = caps_off.xpm caps_on.xpm num_off.xpm num_on.xpm
+
+ xkb.so: main.o
+- $(CC) $(FLAGS) main.o -o xkb.so $(LIBS) $(LFLAGS)
++ $(CC) $(CFLAGS) $(FLAGS) $(LDFLAGS) main.o -o xkb.so $(LIBS) $(LFLAGS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
+@@ -25,4 +23,4 @@
+ $(INSTALL_PROGRAM) xkb.so $(PLUGIN_DIR)
+
+ main.o: main.c $(PIX)
+- $(CC) $(FLAGS) -c main.c
++ $(CC) $(CFLAGS) $(FLAGS) $(LDFLAGS) -c main.c