summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch')
-rw-r--r--x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch122
1 files changed, 122 insertions, 0 deletions
diff --git a/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch b/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
new file mode 100644
index 000000000000..3383c9f5baed
--- /dev/null
+++ b/x11-plugins/bubblemon/files/bubblemon-1.46-gtk.patch
@@ -0,0 +1,122 @@
+--- bubblemon.c
++++ bubblemon.c
+@@ -58,6 +58,7 @@
+ #include <gdk/gdk.h>
+ #include <gdk/gdkx.h>
+ #include <X11/Xresource.h>
++#include <gtk/gtk.h>
+
+ #include "include/master.xpm"
+ #include "include/bubblemon.h"
+@@ -575,7 +576,7 @@
+ attri.colormap = gdk_colormap_get_system();
+ attri.wmclass_name = "bubblemon";
+ attri.wmclass_class = "bubblemon";
+- attri.window_type = GDK_WINDOW_TOPLEVEL;
++ attri.window_type = GDK_WINDOW_CHILD;
+
+ bm.iconwin = gdk_window_new(bm.win, &attri,
+ GDK_WA_TITLE | GDK_WA_WMCLASS);
+@@ -593,7 +594,6 @@
+ wmhints.window_group = win;
+ wmhints.flags =
+ StateHint | IconWindowHint | IconPositionHint | WindowGroupHint;
+- XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
+
+ bm.gc = gdk_gc_new(bm.win);
+
+@@ -606,6 +606,7 @@
+ gdk_window_set_back_pixmap(bm.iconwin, bm.pixmap, False);
+
+ gdk_window_show(bm.win);
++ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
+ #ifdef KDE_DOCKAPP
+ /* makes the dockapp visible inside KDE wm */
+ gdk_window_show(bm.iconwin);
+--- Makefile
++++ Makefile
+@@ -11,30 +11,49 @@
+
+ # no user serviceable parts below
+ EXTRA += $(WMAN)
++# gtk cflags and gtk lib flags
++GTK2_CFLAGS = $(shell pkg-config gtk+-2.0 --cflags)
++GTK2_LIBS = $(shell pkg-config gtk+-2.0 --libs)
++
++
+ # optimization cflags
+-CFLAGS = -O3 -ansi -Wall `gtk-config --cflags` ${EXTRA}
++#CFLAGS = -O3 -Wall ${EXTRA}
++CFLAGS = ${GENTOO_CFLAGS} ${EXTRA}
++
+ # profiling cflags
+-# CFLAGS = -ansi -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
++# CFLAGS = -ansi -Wall -pg -O3 ${EXTRA} -DPRO
+ # test coverage cflags
+-# CFLAGS = -fprofile-arcs -ftest-coverage -Wall -ansi -g `gtk-config --cflags` ${EXTRA} -DPRO
++# CFLAGS = -fprofile-arcs -ftest-coverage -Wall -ansi -g ${EXTRA} -DPRO
+
+
+-SHELL=sh
++SHELL = sh
+ OS = $(shell uname -s)
++SRCS = bubblemon.c
+ OBJS = bubblemon.o
++BUBBLEMON = bubblemon
++
++LDFLAGS = -shared -Wl
++
++STRIP = strip
++
+ CC = gcc
++INSTALLMAN = -m 644
++
++
+
+ # special things for Linux
+ ifeq ($(OS), Linux)
+- OBJS += sys_linux.o
+- LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
+- INSTALL = -m 755
++ SRCS += sys_linux.c
++ OBJS += sys_linux.o
++ INSTALL = -m 755
++ INSTALLMAN = -m 644
+ endif
+
+ # special things for FreeBSD
+ ifeq ($(OS), FreeBSD)
++ SRCS += sys_freebsd.c
+ OBJS += sys_freebsd.o
+- LIBS = `gtk-config --libs | sed "s/-lgtk//g"` -lkvm
++ LIBS = -lkvm
+ INSTALL = -c -g kmem -m 2755 -o root
+ endif
+
+@@ -62,17 +81,21 @@
+ ifeq ($(COMPILER), gcc)
+ CFLAGS=-O3 -Wall
+ endif
+- CFLAGS +=`gtk-config --cflags` ${EXTRA}
++ CFLAGS += ${EXTRA}
++ SRCS += sys_sunos.c
+ OBJS += sys_sunos.o
+- LIBS = `gtk-config --libs` -lkstat -lm
++ LIBS = -lkstat -lm
+ INSTALL = -m 755
+ endif
+
++all: $(BUBBLEMON)
+
+-all: bubblemon
++bubblemon: clean_obj
++ $(CC) $(GTK2_CFLAGS) $(CFLAGS) -o $(BUBBLEMON) \
++ $(LIBS) $(GTK2_LIBS) $(SRCS)
+
+-bubblemon: $(OBJS)
+- $(CC) $(CFLAGS) -o bubblemon $(OBJS) $(LIBS)
++clean_obj:
++ rm -rf *.o
+
+ clean:
+ rm -f bubblemon *.o *.bb* *.gcov gmon.* *.da *~