summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-09-30 12:51:00 +0200
committerJeroen Roovers <jer@gentoo.org>2017-09-30 12:51:18 +0200
commit63b0a80b19fa5865c82d575fcb5b004f730db314 (patch)
tree864375a3655ce1c5939566564cd5e9ce1a2a0f24 /x11-misc
parentdev-libs/libtasn1: stable 4.12-r1 for hppa, bug #627014 (diff)
downloadgentoo-63b0a80b19fa5865c82d575fcb5b004f730db314.tar.gz
gentoo-63b0a80b19fa5865c82d575fcb5b004f730db314.tar.bz2
gentoo-63b0a80b19fa5865c82d575fcb5b004f730db314.zip
x11-misc/rofi: Version bump.
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.4.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index f6e853dbadd4..c68a588a4892 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1 +1,2 @@
DIST rofi-1.3.1.tar.xz 211732 SHA256 b52cf1170f5c7c38f6399ee44f23ebbd87ac349d6a34f32f5d169966765c87e8 SHA512 a96c53ad268883277c4ff0ee3267ff7fab4d4a93a982019ce19ea82771b65c32d56216d777494853bffd18481400af72ed777f88cce4b26d7d1b8980a997f6c6 WHIRLPOOL 47ca4050853888fda4ae9dc203c3d4a47284780d8d1506b12f4bb14cb947a8a7e96b3674203b518ada6b9bbd0e5718d49a42f89a2ecbdf26b3fdacce9d9fee6f
+DIST rofi-1.4.1.tar.xz 337988 SHA256 90fbca9b4b4bc4eaf55a8d5115e880611137faaa44b0d929694cb40ef9face76 SHA512 3db3642819761bcfc99e7e8c6f09dde0c85d34be84541ac376ce09032a5c20aa7d64d6e12c9e21bfbee7d2db2611d24a12539548b662df6fb061d91cca1eb808 WHIRLPOOL 09bbb4d2fe1d9b046b7684636f296fcbf4c77c4ffc3bb04c54d949886b29d7c6d9632d6132677a35575671fec7e234df096f15a4d36892e8ffea5924d01335b0
diff --git a/x11-misc/rofi/rofi-1.4.1.ebuild b/x11-misc/rofi/rofi-1.4.1.ebuild
new file mode 100644
index 000000000000..5430effcf8c7
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}