summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-04-05 23:16:30 -0400
committerMatt Turner <mattst88@gentoo.org>2024-04-05 23:17:17 -0400
commit2e815b654c67e15511b0c7bc633132b69124953b (patch)
tree4de4f1c0a48335a6128153f55af20513243531b5 /x11-misc
parentapp-laptop/framework-laptop-kmod: add 0_pre20240405 (diff)
downloadgentoo-2e815b654c67e15511b0c7bc633132b69124953b.tar.gz
gentoo-2e815b654c67e15511b0c7bc633132b69124953b.tar.bz2
gentoo-2e815b654c67e15511b0c7bc633132b69124953b.zip
x11-misc/compose-tables: Version bump to 1.8.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/compose-tables/Manifest1
-rw-r--r--x11-misc/compose-tables/compose-tables-1.8.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index 323078f4bdf6..8c3df55e4480 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1,2 +1,3 @@
DIST libX11-1.8.7.tar.xz 1859256 BLAKE2B 335d8af91c13aba11255c266c4687a7f66b021207a92485d723b4107601bbabb6a0e5535241a3bcff4ac9a99142730d2b3d2e2eaff86b507fee5b35a2590d792 SHA512 d53bfc18f38d339a6a695b09835b2ae96b323881678bfe7ddca697605e3bdf4102ff49cc3078880a6c55b5977fcdd0aadaf5429086132de3a5bda302f79a2fa6
DIST libX11-1.8.8.tar.xz 1872808 BLAKE2B d180932c65c565d113ae768bb0035aa98ff7dd265de9a7907f54f994b1520d7fc67699032450afc5d8f9427247f73dcf71259ff6a3f734d71f6e8b6181c6891b SHA512 4e7ce8f2d88b9475f960ea1d5730ece8953509e0c057cf2d0a2f5fa6a36e6577b0dcd7f16ac91b8fdd804aabec6d7e8f3067a3a8667bd2e41d72dd68ab70ef82
+DIST libX11-1.8.9.tar.xz 1811900 BLAKE2B 8858157ac490d65e19500bfbb2ab773a3a30041f8a757ff22fff8fb0124044b8bb826f6dff4115230c757a175b61a3f7d596d976d98be760085749878d64f871 SHA512 737af91818537295ac86be601b1e3d7e37d150716ec549580913b7cc9a44fee7a6ce9dbc3d46167eed91f23fe857c4dd355ed8f8440fe5fbbf8e9ebe47091b96
diff --git a/x11-misc/compose-tables/compose-tables-1.8.9.ebuild b/x11-misc/compose-tables/compose-tables-1.8.9.ebuild
new file mode 100644
index 000000000000..ade5421accec
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.8.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+# RDEPEND=""
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+ )
+ xorg-3_src_configure
+}
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}