summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-08 00:09:20 +0000
committerSam James <sam@gentoo.org>2022-02-08 00:09:20 +0000
commit137b49a84fb9a3edc65f82d49c6a181580ba00f0 (patch)
treefb70b1ccd3e473ead336c187f00f8ec475557e11 /x11-misc
parentx11-misc/lineakd: fix libdl linkage, other modernisation (diff)
downloadgentoo-137b49a84fb9a3edc65f82d49c6a181580ba00f0.tar.gz
gentoo-137b49a84fb9a3edc65f82d49c6a181580ba00f0.tar.bz2
gentoo-137b49a84fb9a3edc65f82d49c6a181580ba00f0.zip
x11-misc/lineakd: fix revisions
Closes: https://bugs.gentoo.org/722372 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0-r3.ebuild38
-rw-r--r--x11-misc/lineakd/lineakd-0.9.0-r4.ebuild65
2 files changed, 82 insertions, 21 deletions
diff --git a/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild b/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
index 8f2fca9f6c7c..8b2026bc430b 100644
--- a/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
+++ b/x11-misc/lineakd/lineakd-0.9.0-r3.ebuild
@@ -1,53 +1,49 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
-
-inherit autotools
+EAPI=7
+inherit multilib
MY_P=${P/.0/}
+
DESCRIPTION="Linux support for Easy Access and Internet Keyboards"
HOMEPAGE="http://lineak.sourceforge.net"
SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="amd64 ppc sparc x86"
IUSE="debug"
-RDEPEND="x11-libs/libICE
+RDEPEND="
+ x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
- x11-libs/libXext"
-DEPEND="${RDEPEND}
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
x11-base/xorg-proto
x11-libs/libxkbfile
x11-libs/libXt
- x11-libs/libXtst"
+ x11-libs/libXtst
+"
+S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-DELL-XPS-M1330-XOrg-1_5.patch
- "${FILESDIR}"/${P}-automake-linking-libdl.patch
)
-src_prepare() {
- default
-
- eautoreconf
-}
-
src_configure() {
- # admin/lineakd.m4.in contains Bashisms but fixes it causes a confusing
- # autotools avalanche, so workaround it with CONFIG_SHELL as bash.
- CONFIG_SHELL="${BROOT}/bin/bash" econf \
+ econf \
$(use_enable debug) \
- --with-x
+ --with-x \
+ --disable-static
}
src_install() {
- sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile || die
+ sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile
dodir /usr/share/man/man8
diff --git a/x11-misc/lineakd/lineakd-0.9.0-r4.ebuild b/x11-misc/lineakd/lineakd-0.9.0-r4.ebuild
new file mode 100644
index 000000000000..8f2fca9f6c7c
--- /dev/null
+++ b/x11-misc/lineakd/lineakd-0.9.0-r4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=${P/.0/}
+DESCRIPTION="Linux support for Easy Access and Internet Keyboards"
+HOMEPAGE="http://lineak.sourceforge.net"
+SRC_URI="mirror://sourceforge/lineak/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libxkbfile
+ x11-libs/libXt
+ x11-libs/libXtst"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-DELL-XPS-M1330-XOrg-1_5.patch
+ "${FILESDIR}"/${P}-automake-linking-libdl.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # admin/lineakd.m4.in contains Bashisms but fixes it causes a confusing
+ # autotools avalanche, so workaround it with CONFIG_SHELL as bash.
+ CONFIG_SHELL="${BROOT}/bin/bash" econf \
+ $(use_enable debug) \
+ --with-x
+}
+
+src_install() {
+ sed -i -e 's:$(DESTDIR)${DESTDIR}:$(DESTDIR):' lineakd/Makefile || die
+
+ dodir /usr/share/man/man8
+
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc AUTHORS README TODO
+
+ keepdir /usr/$(get_libdir)/lineakd/plugins
+
+ insinto /etc/lineak
+ doins lineakd.conf.example lineakd.conf.kde.example
+
+ find "${ED}"/usr/share/man -name '*.bz2' -exec bunzip2 {} \; || die
+ find "${ED}" -name '*.la' -delete || die
+}