summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/dzen/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/dzen/files')
-rw-r--r--x11-misc/dzen/files/dzen-0.9.5-config-default.patch95
-rw-r--r--x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch11
2 files changed, 106 insertions, 0 deletions
diff --git a/x11-misc/dzen/files/dzen-0.9.5-config-default.patch b/x11-misc/dzen/files/dzen-0.9.5-config-default.patch
new file mode 100644
index 000000000000..2fcdddbf6a68
--- /dev/null
+++ b/x11-misc/dzen/files/dzen-0.9.5-config-default.patch
@@ -0,0 +1,95 @@
+--- a/config.mk
++++ b/config.mk
+@@ -4,7 +4,7 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
++PREFIX = /usr
+ MANPREFIX = ${PREFIX}/share/man
+
+ X11INC = /usr/X11R6/include
+@@ -19,55 +19,12 @@
+ # Comment : Add # to the beginning of the respective lines
+
+ ## Option 1: No Xinerama no XPM no XFT
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\"
+-
+-
+-## Option 2: No Xinerama with XPM
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXpm
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XPM
+-
+-
+-# Option 3: With Xinerama no XPM
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXinerama
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XINERAMA
+-
+-
+-## Option 4: With Xinerama and XPM
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXinerama -lXpm
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XINERAMA -DDZEN_XPM
+-
+-
+-## Option 5: With XFT
+-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs xft`
+-CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XFT `pkg-config --cflags xft`
+-
+-
+-## Option 6: With XPM and XFT
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXpm `pkg-config --libs xft`
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XPM -DDZEN_XFT `pkg-config --cflags xft`
+-
+-
+-## Option 7: With Xinerama and XPM and XFT
+-#LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 -lXinerama -lXpm `pkg-config --libs xft`
+-#CFLAGS = -Wall -Os ${INCS} -DVERSION=\"${VERSION}\" -DDZEN_XINERAMA -DDZEN_XPM -DDZEN_XFT `pkg-config --cflags xft`
+-
+-
++LIBS = -lX11
++CFLAGS += -Wall ${INCS} -DVERSION=\"${VERSION}\"
+
+ # END of feature configuration
+
+-
+-LDFLAGS = ${LIBS}
+-
+-# Solaris, uncomment for Solaris
+-#CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+-#LDFLAGS = ${LIBS}
+-#CFLAGS += -xtarget=ultra
+-
+-# Debugging
+-#CFLAGS = ${INCS} -DVERSION=\"${VERSION}\" -std=gnu89 -pedantic -Wall -W -Wundef -Wendif-labels -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-align -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wdisabled-optimization -O2 -pipe -DDZEN_XFT `pkg-config --cflags xft`
+-#LDFLAGS = ${LIBS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+-CC = gcc
+-LD = ${CC}
++LD = $(CC)
+--- a/gadgets/config.mk
++++ b/gadgets/config.mk
+@@ -1,7 +1,7 @@
+ # Customize below to fit your system
+
+ # paths
+-PREFIX = /usr/local
++PREFIX = /usr
+ MANPREFIX = ${PREFIX}/share/man
+
+ X11INC = /usr/X11R6/include
+@@ -10,9 +10,8 @@
+ X11LIB = /usr/X11R6/lib
+ LIBS = -L/usr/lib
+
+-CFLAGS = -Os ${INCS}
+-LDFLAGS = ${LIBS}
++CFLAGS += ${INCS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+-CC = gcc
+-LD = ${CC}
++LD = $(CC)
diff --git a/x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch b/x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch
new file mode 100644
index 000000000000..008fd6455014
--- /dev/null
+++ b/x11-misc/dzen/files/dzen-0.9.5-off-by-one.patch
@@ -0,0 +1,11 @@
+--- a/main.c
++++ b/main.c
+@@ -109,7 +109,7 @@
+ rem = NULL;
+ }
+ while(off < len) {
+- if(i > MAX_LINE_LEN) {
++ if(i == MAX_LINE_LEN - 1) {
+ outbuf[i] = '\0';
+ return ++off;
+ }