summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/cdm/cdm-0.5.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/cdm/cdm-0.5.3.ebuild')
-rw-r--r--x11-misc/cdm/cdm-0.5.3.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/x11-misc/cdm/cdm-0.5.3.ebuild b/x11-misc/cdm/cdm-0.5.3.ebuild
new file mode 100644
index 000000000000..4d5474af85eb
--- /dev/null
+++ b/x11-misc/cdm/cdm-0.5.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base pam eutils
+
+DESCRIPTION="The Console Display Manager"
+HOMEPAGE="https://wiki.archlinux.org/index.php/CDM"
+SRC_URI="http://dev.gentoo.org/~gienah/snapshots/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam consolekit"
+REQUIRED_USE="consolekit? ( pam )"
+
+DEPEND="app-shells/bash"
+
+RDEPEND="${DEPEND}
+ dev-util/dialog
+ x11-apps/xdpyinfo
+ x11-apps/xinit
+ consolekit? ( sys-auth/consolekit
+ sys-apps/dbus )
+ pam? ( virtual/pam )"
+
+PATCHES=("${FILESDIR}/${PN}-0.5.3-invalid-MIT-cookie.patch")
+
+src_prepare() {
+ base_src_prepare
+ if ! use consolekit; then
+ sed -e 's@consolekit=yes@consolekit=no@' \
+ -i "${S}/src/cdmrc" || die "Could not turn off consolekit in cdmrc"
+ fi
+}
+
+src_install() {
+ if use pam ; then
+ pamd_mimic system-local-login cdm auth account session
+ fi
+
+ insinto /usr/bin/
+ insopts -m0755
+ dobin src/${PN}
+
+ insinto /etc
+ insopts -Dm644
+ doins src/cdmrc
+
+ insinto /usr/share/${PN}
+ insopts -m644
+ doins src/xinitrc*
+
+ insinto /etc/profile.d/
+ insopts -Dm755
+ doins src/zzz-${PN}-profile.sh
+
+ # Install themes
+ insinto /usr/share/${PN}/themes
+ doins src/themes/*
+ # Copy documentation manually
+ dodoc CHANGELOG
+}
+
+pkg_postinst() {
+ einfo "In order to use CDM you must first edit your /etc/cdmrc"
+ einfo "At least these should be edited before you start using CDM:"
+ einfo "wmbinlist=(awesome openbox-session startkde startxfce4 gnome-session)"
+ einfo "wmdisplist=(Awesome Openbox KDE Xfce Gnome)"
+ einfo "Add whatever WM/DE you have."
+ einfo "Then just login with your username"
+ ewarn "Remove xdm from default runlevel"
+}