summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-10-08 18:00:34 -0600
committerMatt Turner <mattst88@gentoo.org>2023-10-09 16:31:57 -0400
commitd4cb3846fc9bc4078299ab57f7e4f6c2d14b314e (patch)
treed3e7dda4bebbba810420e6deaf214efef5dff340 /x11-libs
parentwww-client/chromium: drop 117.0.5938.132 (diff)
downloadgentoo-d4cb3846fc9bc4078299ab57f7e4f6c2d14b314e.tar.gz
gentoo-d4cb3846fc9bc4078299ab57f7e4f6c2d14b314e.tar.bz2
gentoo-d4cb3846fc9bc4078299ab57f7e4f6c2d14b314e.zip
x11-libs/libxkbcommon: add 1.6.0
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/33256 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 0328e5e29ab7..6b78dd3f50e5 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1 +1,2 @@
DIST libxkbcommon-1.5.0.tar.xz 472700 BLAKE2B 5dcfb514c297f71629f20b444cb29c5d26ce9def1c1173a125fb0c0c259d76194fcef7a407d8efda2d2d87c9b90abac34e2fc1742cfd6053df511a3ef205c8ef SHA512 bbba6665f052c04c7450413cc5e2badd6bfd41326b0e4c60e3ec01d730cae695fd34ce2662b8a91ece7a76b974a0ea330f7462dd5d2db148b0d0da26264ced9c
+DIST libxkbcommon-1.6.0.tar.xz 510456 BLAKE2B ffd373161f12ea6448a9206f57710355ab65b81ebab5dce74e4dfcee1bdc9175406fc434560648f5933b83cac163099c8564c3add6f51d34856def39ab077850 SHA512 4f93225eada1c5d0806bbc01f72d82d72729f4580ade963ff6a386711c9b2232aae5213c8488abf01c3b81f0e1fdb7f4d8a4d3786113ccc134251ff164c4be5c
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild
new file mode 100644
index 000000000000..ea6a904b5f8e
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="Keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ wayland? ( dev-util/wayland-scanner )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.2.0[${MULTILIB_USEDEP}] )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+ x11-misc/xkeyboard-config
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ mv "${ED}"/usr/share/doc/{${PN},${P}} || die
+ fi
+}