summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/tslib/tslib-1.0-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/tslib/tslib-1.0-r3.ebuild')
-rw-r--r--x11-libs/tslib/tslib-1.0-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/tslib/tslib-1.0-r3.ebuild b/x11-libs/tslib/tslib-1.0-r3.ebuild
new file mode 100644
index 000000000000..72df67001d22
--- /dev/null
+++ b/x11-libs/tslib/tslib-1.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs autotools multilib-minimal
+
+PATCH_VER="5"
+DESCRIPTION="Touchscreen Access Library"
+HOMEPAGE="https://github.com/kergoth/tslib"
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+#extras arctic2 collie corgi h3600 linear-h2200 mk712 ucb1x00"
+
+DOCS=( AUTHORS NEWS README )
+
+src_prepare() {
+ # patches come from buildroot + openembedded + suse
+ EPATCH_SUFFIX=patch epatch "${WORKDIR}"/patch
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # compile everything. INSTALL_MASK= what you don't want.
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-linear --enable-dejitter \
+ --enable-variance --enable-pthres \
+ --enable-input --enable-shared \
+ --enable-arctic2 --enable-collie \
+ --enable-corgi --enable-h3600 \
+ --enable-linear-h2200 --enable-mk712 \
+ --enable-ucb1x00 --disable-debug
+}