summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-06-21 20:14:12 -0400
committerMatt Turner <mattst88@gentoo.org>2019-06-21 20:27:53 -0400
commitcf7d005d74e118d4beddd5202f337b0be7fe8ca0 (patch)
tree0523d17e43935c59269f177cf52cfc4b090fe98e /x11-libs/libXt
parentapp-emulation/winetricks: Sync with ::wine (diff)
downloadgentoo-cf7d005d74e118d4beddd5202f337b0be7fe8ca0.tar.gz
gentoo-cf7d005d74e118d4beddd5202f337b0be7fe8ca0.tar.bz2
gentoo-cf7d005d74e118d4beddd5202f337b0be7fe8ca0.zip
x11-libs/libXt: Version bump to 1.2.0
Closes: https://bugs.gentoo.org/679938 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXt')
-rw-r--r--x11-libs/libXt/Manifest1
-rw-r--r--x11-libs/libXt/libXt-1.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/libXt/Manifest b/x11-libs/libXt/Manifest
index a368cc113eea..0be136cb0ceb 100644
--- a/x11-libs/libXt/Manifest
+++ b/x11-libs/libXt/Manifest
@@ -1 +1,2 @@
DIST libXt-1.1.5.tar.bz2 771567 BLAKE2B c3624f1ab81fdace1b2eef8749807e9a2157ec6f60e2f5f8b463aae088057d4eb82f9c6de547e286798b98f68be8f8097ff291b490baf49a4204e62566c1a9c4 SHA512 29828cfc021b60e0a0b5ff0321801db20f12bd635866cd000b35a23736b5477a3d1e5f936a1124ed3e3f4c0e7a27cb8744dbb5ab4fbcd45c817a13877081e05b
+DIST libXt-1.2.0.tar.bz2 810521 BLAKE2B dc60b8fb126f465122eec4df287d5a0d12e483457ba20abbd04a17a8a5fb8a1073d8765236b8020353ec3c5f472b1580ba7a99d6896ce5fcdabaed5f4fbc6753 SHA512 06248508b6fe5dfba8ceb4518475f656162351d78136eeb5d65086d680dabe9aca7bba3c94347f9c13ef03f82dab3ac19d0952ee610bc8c51c14cee7cf65f0b1
diff --git a/x11-libs/libXt/libXt-1.2.0.ebuild b/x11-libs/libXt/libXt-1.2.0.ebuild
new file mode 100644
index 000000000000..a13cc801954e
--- /dev/null
+++ b/x11-libs/libXt/libXt-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org X Toolkit Intrinsics library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="test"
+
+RDEPEND="
+ >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libSM-1.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( dev-libs/glib )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable test unit-tests)
+ --without-fop
+ )
+}