summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-10-30 11:26:16 -0400
committerMatt Turner <mattst88@gentoo.org>2024-10-30 11:28:03 -0400
commit864354208fab844df49264d818a86f905a147052 (patch)
tree0873ee5e6b74ab875d0a91976ed97fb67bff56cf /x11-drivers
parentdev-util/desktop-file-utils: Version bump to 0.28 (diff)
downloadgentoo-864354208fab844df49264d818a86f905a147052.tar.gz
gentoo-864354208fab844df49264d818a86f905a147052.tar.bz2
gentoo-864354208fab844df49264d818a86f905a147052.zip
x11-drivers/xf86-input-wacom: Version bump to 1.2.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-wacom/Manifest1
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/Manifest b/x11-drivers/xf86-input-wacom/Manifest
index a27f7120cd9a..c7ff13cf1f5e 100644
--- a/x11-drivers/xf86-input-wacom/Manifest
+++ b/x11-drivers/xf86-input-wacom/Manifest
@@ -1 +1,2 @@
DIST xf86-input-wacom-1.2.2.tar.bz2 649132 BLAKE2B c068317c7ca74dbda336f12c96cf27f7541880aa75f65638d72755d28538614d72e091ca94a7c62c84e5748ebfa459fe3f930edcd55e53797301719630055e8f SHA512 60c490ff67ff6b4719a2683f5368ef3fca3d97ced92cf251bb4c7610d24e9df1d3577f50b625621025b2e2d1abf8f8aac2dbb7629220664992f6b85a0a84adcb
+DIST xf86-input-wacom-1.2.3.tar.bz2 674630 BLAKE2B a3556579d88ec2b35e60928c6429ef0a374afe6a1873e70fca655c31749cc749810b7e348f075a3d8459ec6278ba5d67c7754cfe58b4050e112a5eef2e26da0c SHA512 1419f0d3103025d2f5d0b88b74c29f9b7cb9eb4f05119f8a469384af12b2821653596ce5adac918d8875e622cfccbd47ea9c6fc43d28c72091b09ec674e22de9
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild
new file mode 100644
index 000000000000..e1af227b997d
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-1.2.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd udev xorg-3 meson
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="https://linuxwacom.github.io/"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ virtual/libudev:="
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present HID_WACOM; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " HID support --->"
+ ewarn " Special HID drivers --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ xorg-3_flags_setup
+
+ local emesonargs=(
+ -Dsystemd-unit-dir="$(systemd_get_systemunitdir)"
+ -Dudev-rules-dir="$(get_udevdir)/rules.d"
+ $(meson_feature test unittests)
+ -Dwacom-gobject=disabled
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}