summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-04 17:06:15 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-04 17:13:24 -0500
commit12d6606b5f55fb0f5712814653942cd889de8579 (patch)
tree0038bbf2e75cd3196a6fcafa4a4fce7d50f3a24f /x11-apps/xditview
parentx11-apps/xkbutils: Version bump to 1.0.6 (diff)
downloadgentoo-12d6606b5f55fb0f5712814653942cd889de8579.tar.gz
gentoo-12d6606b5f55fb0f5712814653942cd889de8579.tar.bz2
gentoo-12d6606b5f55fb0f5712814653942cd889de8579.zip
x11-apps/xditview: Version bump to 1.0.7
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-apps/xditview')
-rw-r--r--x11-apps/xditview/Manifest1
-rw-r--r--x11-apps/xditview/xditview-1.0.7.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-apps/xditview/Manifest b/x11-apps/xditview/Manifest
index 61479e94719c..97099f980544 100644
--- a/x11-apps/xditview/Manifest
+++ b/x11-apps/xditview/Manifest
@@ -1 +1,2 @@
DIST xditview-1.0.6.tar.xz 143848 BLAKE2B bf832e17631a12f58ad194b1ddcf7a63a31e04f005ce883798f892284c8ad64ae40f15f5c1d781179333ce212e989de9b45cc53881079818e5c2f0b6087e3b5c SHA512 249769d27980e9a69ac8f056f329dfa514f3ab6267d6ed69814c5695f315d2a7021c560a0e26fdd2568290a071793d7f2eafdd92f9981ed556047deb244ebf5a
+DIST xditview-1.0.7.tar.xz 146392 BLAKE2B d0a3300698bf263cc790bf364f849c64cb2e12b10fa6423dd893d188bb06998c29740331e268a15a378a972df0d4b7b7362896844da262297ec8f3cd86f458ff SHA512 da7e80cd9fbb5da0ec4949c6fed0bad135a2490767f030e60f1c51a9f5a62379572bf8b4dd6dec2fe824152d090470e62fce12c9144aaa1be1b48ddbc3b2910b
diff --git a/x11-apps/xditview/xditview-1.0.7.ebuild b/x11-apps/xditview/xditview-1.0.7.ebuild
new file mode 100644
index 000000000000..c19d912e4a70
--- /dev/null
+++ b/x11-apps/xditview/xditview-1.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="display ditroff output"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="xft"
+
+RDEPEND="
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libX11
+ xft? (
+ x11-libs/libXft
+ x11-libs/libXrender
+ media-libs/fontconfig
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with xft)
+ )
+ xorg-3_src_configure
+}