summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/ardesia
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/ardesia')
-rw-r--r--x11-apps/ardesia/Manifest1
-rw-r--r--x11-apps/ardesia/ardesia-1.0.ebuild37
-rw-r--r--x11-apps/ardesia/metadata.xml31
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-apps/ardesia/Manifest b/x11-apps/ardesia/Manifest
new file mode 100644
index 000000000000..66242c315e0a
--- /dev/null
+++ b/x11-apps/ardesia/Manifest
@@ -0,0 +1 @@
+DIST ardesia-1.0.tar.bz2 2831274 SHA256 6386ef36353220951d0f6c891df62976e171c359fad99451cd017e3c79b8ef32 SHA512 cbd3a95cd8a628830f79d9920dd7a58af295fbc335648f4bdaf720cbcc8d87a74da52195649b54f3b651aa52b4d655505f47d081511468caabace21e40481e00 WHIRLPOOL bb40783111fca1f3bb5a3ddf4ebab72bf5b073b836d2afd8681bc00bb5c1c6b23002ca0acc80680e5ac2dafb0c7c7770950d468edc64f05b8d58c843e9b08d90
diff --git a/x11-apps/ardesia/ardesia-1.0.ebuild b/x11-apps/ardesia/ardesia-1.0.ebuild
new file mode 100644
index 000000000000..9ceffa501eb0
--- /dev/null
+++ b/x11-apps/ardesia/ardesia-1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+HOMEPAGE="http://code.google.com/p/ardesia/"
+SRC_URI="http://ardesia.googlecode.com/files/${P}.tar.bz2"
+DESCRIPTION="Color, record and share free-hand annotations on screen and on network"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cwiid"
+
+RDEPEND="dev-libs/atk
+ dev-libs/libsigsegv
+ media-libs/fontconfig
+ media-libs/libpng
+ sci-libs/gsl
+ sys-devel/gettext
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ gnome-extra/libgsf
+ cwiid? ( app-misc/cwiid )"
+DEPEND="${RDEPEND}
+ x11-misc/xdg-utils"
+
+src_install() {
+ emake DESTDIR="${D}" ardesiadocdir="/usr/share/doc/${P}" install || die "make install ardesia failed"
+}
+
+pkg_postinst() {
+ elog "Ardesia requires a Composite Manager, such as Compiz"
+ elog "Metacity with compositing, Kwin, etc in order to run"
+ echo
+}
diff --git a/x11-apps/ardesia/metadata.xml b/x11-apps/ardesia/metadata.xml
new file mode 100644
index 000000000000..1ab497645126
--- /dev/null
+++ b/x11-apps/ardesia/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>ziapannocchia@gmail.com</email>
+ <name>Marco Clocchiatti</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<longdescription lang="en">
+Ardesia enables you to make colored free-hand annotations on your computer screen,
+record it and share on the network.
+</longdescription>
+<use>
+ <flag name="cwiid">
+ cwiid support: collection of Linux tools written in C for interfacing to
+ the Nintendo Wiimote.
+ </flag>
+</use>
+<upstream>
+ <maintainer status="active">
+ <email>alpha@paranoici.org</email>
+ <name>Pietro Pilloli</name>
+ </maintainer>
+ <changelog>http://code.google.com/p/ardesia/source/list</changelog>
+ <doc>http://code.google.com/p/ardesia/wiki/FAQ</doc>
+ <bugs-to>http://code.google.com/p/ardesia/issues/list</bugs-to>
+ <remote-id type="google-code">http://code.google.com/p/ardesia</remote-id>
+</upstream>
+</pkgmetadata>
+