summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-28 01:58:10 +0100
committerSam James <sam@gentoo.org>2023-04-28 01:58:10 +0100
commita6e3c66aabe4e19161dfe6f389af0eb349fb0cf4 (patch)
tree40883483dc546eac8c33df6906de92d5a6ee543a /www-servers/uwsgi
parentwww-servers/h2o: add upstream libressl patch (diff)
downloadgentoo-a6e3c66aabe4e19161dfe6f389af0eb349fb0cf4.tar.gz
gentoo-a6e3c66aabe4e19161dfe6f389af0eb349fb0cf4.tar.bz2
gentoo-a6e3c66aabe4e19161dfe6f389af0eb349fb0cf4.zip
www-servers/uwsgi: fix build w/ newer php
Closes: https://bugs.gentoo.org/904664 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-servers/uwsgi')
-rw-r--r--www-servers/uwsgi/files/uwsgi-2.0.21-libphp-version.patch13
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.21.ebuild1
2 files changed, 14 insertions, 0 deletions
diff --git a/www-servers/uwsgi/files/uwsgi-2.0.21-libphp-version.patch b/www-servers/uwsgi/files/uwsgi-2.0.21-libphp-version.patch
new file mode 100644
index 000000000000..8b0276c3cb89
--- /dev/null
+++ b/www-servers/uwsgi/files/uwsgi-2.0.21-libphp-version.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/904664
+--- a/plugins/php/uwsgiplugin.py
++++ b/plugins/php/uwsgiplugin.py
+@@ -14,6 +14,9 @@
+
+ php_version = os.popen(PHPPATH + ' --version').read().rstrip().split('.')[0]
+
++if php_version == '8' :
++ php_version = ''
++
+ CFLAGS = [os.popen(PHPPATH + ' --includes').read().rstrip(), '-Wno-sign-compare']
+ LDFLAGS = os.popen(PHPPATH + ' --ldflags').read().rstrip().split()
+
diff --git a/www-servers/uwsgi/uwsgi-2.0.21.ebuild b/www-servers/uwsgi/uwsgi-2.0.21.ebuild
index 6283e0d78a3e..e141c804fb8a 100644
--- a/www-servers/uwsgi/uwsgi-2.0.21.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.21.ebuild
@@ -152,6 +152,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-php82.patch
"${FILESDIR}"/${P}-python-unicode.patch
+ "${FILESDIR}"/${P}-libphp-version.patch
)
pkg_setup() {