summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-misc/zoneminder/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-misc/zoneminder/files')
-rw-r--r--www-misc/zoneminder/files/10_zoneminder.conf18
-rw-r--r--www-misc/zoneminder/files/README.gentoo27
-rw-r--r--www-misc/zoneminder/files/conf.d6
-rw-r--r--www-misc/zoneminder/files/init.d26
-rw-r--r--www-misc/zoneminder/files/zoneminder-1.24.2-db_upgrade_script_location.patch11
-rw-r--r--www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch34
6 files changed, 122 insertions, 0 deletions
diff --git a/www-misc/zoneminder/files/10_zoneminder.conf b/www-misc/zoneminder/files/10_zoneminder.conf
new file mode 100644
index 000000000000..277d680d24b4
--- /dev/null
+++ b/www-misc/zoneminder/files/10_zoneminder.conf
@@ -0,0 +1,18 @@
+ScriptAlias /cgi-bin/zms "/usr/libexec/zoneminder/cgi-bin/zms"
+ScriptAlias /cgi-bin/nph-zms "/usr/libexec/zoneminder/cgi-bin/nph-zms"
+
+<Directory "/usr/libexec/zoneminder/cgi-bin">
+ AllowOverride All
+ Options ExecCGI
+ Order allow,deny
+ Allow from all
+</Directory>
+
+Alias /zoneminder "%ZM_WEBDIR%"
+
+<Directory "%ZM_WEBDIR%">
+ Options -Indexes MultiViews FollowSymLinks
+ AllowOverride All
+ Order allow,deny
+ Allow from all
+</Directory>
diff --git a/www-misc/zoneminder/files/README.gentoo b/www-misc/zoneminder/files/README.gentoo
new file mode 100644
index 000000000000..2ada7c7d0a45
--- /dev/null
+++ b/www-misc/zoneminder/files/README.gentoo
@@ -0,0 +1,27 @@
+1. If this is a new installation, you will need to create a MySQL
+ database for zoneminder to use
+ (see https://wiki.gentoo.org/wiki/MySQL/Startup_Guide).
+ E.g., when logged into mysql as root,
+ mysql> CREATE DATABASE \`zm\`;
+ mysql> GRANT ALL ON zm.* TO 'zmuser'@'localhost' IDENTIFIED BY 'topsecretpassword';
+ Once you completed that you should execute the following:
+ cd /usr/share/zoneminder
+ mysql -u zmuser -p < db/zm_create.sql
+
+2. Set your database settings in /etc/zm.conf, including above topsecretpassword
+
+3. Configure apache to use zoneminder, see /usr/share/doc/zoneminder*/10_zoneminder.conf
+ for an example configuration snippet.
+
+4. Enable PHP in your webserver configuration,
+ enable short_open_tags in php.ini,
+ set the time zone in php.ini,
+ and restart/reload the webserver.
+
+5. Start the zoneminder daemon:
+ /etc/init.d/zoneminder start
+
+6. Finally point your browser to http://your.webserver/zoneminder
+
+If you are upgrading, you will need to run the zmupdate.pl script:
+ /usr/bin/zmupdate.pl --version=oldversionnumber [--user=zmuser --pass=topsecretpassword]
diff --git a/www-misc/zoneminder/files/conf.d b/www-misc/zoneminder/files/conf.d
new file mode 100644
index 000000000000..d2e03363867a
--- /dev/null
+++ b/www-misc/zoneminder/files/conf.d
@@ -0,0 +1,6 @@
+ZM_SCRIPT=/usr/bin/zmpkg.pl
+
+# Commands for starting and stopping the server
+
+CMD_START="${ZM_SCRIPT} start"
+CMD_STOP="${ZM_SCRIPT} stop"
diff --git a/www-misc/zoneminder/files/init.d b/www-misc/zoneminder/files/init.d
new file mode 100644
index 000000000000..06435b85f108
--- /dev/null
+++ b/www-misc/zoneminder/files/init.d
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need mysql
+ need apache2
+}
+
+start_pre() {
+ checkpath -d -m 0775 -o apache:apache /var/run/zm
+ checkpath -d -m 0775 -o apache:apache /var/tmp/zm
+}
+
+start() {
+ ebegin "Starting zoneminder"
+ ${CMD_START}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping zoneminder"
+ ${CMD_STOP}
+ eend $?
+}
diff --git a/www-misc/zoneminder/files/zoneminder-1.24.2-db_upgrade_script_location.patch b/www-misc/zoneminder/files/zoneminder-1.24.2-db_upgrade_script_location.patch
new file mode 100644
index 000000000000..41b537c4167a
--- /dev/null
+++ b/www-misc/zoneminder/files/zoneminder-1.24.2-db_upgrade_script_location.patch
@@ -0,0 +1,11 @@
+--- ZoneMinder-1.24.1/zm.conf.in.orig 2009-03-23 13:55:43.000000000 +0000
++++ ZoneMinder-1.24.1/zm.conf.in 2009-03-23 13:57:22.000000000 +0000
+@@ -13,7 +13,7 @@
+ ZM_VERSION=@VERSION@
+
+ # Path to build directory, used mostly for finding DB upgrade scripts
+-ZM_PATH_BUILD=@PATH_BUILD@
++ZM_PATH_BUILD=/usr/share/zoneminder
+
+ # Build time, used to record when to trigger various checks
+ ZM_TIME_BUILD=@TIME_BUILD@
diff --git a/www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch b/www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch
new file mode 100644
index 000000000000..266bd649baa6
--- /dev/null
+++ b/www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch
@@ -0,0 +1,34 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 83e9d81..8619c8b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -171,6 +171,7 @@ else(PCRE_LIBRARIES)
+ set(optlibsnotfound "${optlibsnotfound} PCRE")
+ endif(PCRE_LIBRARIES)
+
++if(HAVE_GCRYPT)
+ # gcrypt (using find_library and find_path)
+ find_library(GCRYPT_LIBRARIES gcrypt)
+ if(GCRYPT_LIBRARIES)
+@@ -187,7 +188,11 @@ if(GCRYPT_LIBRARIES)
+ else(GCRYPT_LIBRARIES)
+ set(optlibsnotfound "${optlibsnotfound} GCrypt")
+ endif(GCRYPT_LIBRARIES)
++else(HAVE_GCRYPT)
++ set(optlibsnotfound "${optlibsnotfound} GCrypt")
++endif(HAVE_GCRYPT)
+
++if(HAVE_GNUTLS)
+ # gnutls (using find_library and find_path)
+ find_library(GNUTLS_LIBRARIES gnutls)
+ if(GNUTLS_LIBRARIES)
+@@ -205,6 +210,9 @@ if(GNUTLS_LIBRARIES)
+ else(GNUTLS_LIBRARIES)
+ set(optlibsnotfound "${optlibsnotfound} GnuTLS")
+ endif(GNUTLS_LIBRARIES)
++else(HAVE_GNUTLS)
++ set(optlibsnotfound "${optlibsnotfound} GnuTLS")
++endif(HAVE_GNUTLS)
+
+ # mysqlclient (using find_library and find_path)
+ find_library(MYSQLCLIENT_LIBRARIES mysqlclient PATH_SUFFIXES mysql)