summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-21 02:00:21 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-21 02:32:54 -0400
commitc20eaf5374d83c9b837fc364bbfae05206495863 (patch)
treec5f311f9dd049a05bef8bac0257598ab4e153284 /www-client
parentwww-client/qutebrowser: version bump to 2.3.1 (diff)
downloadgentoo-c20eaf5374d83c9b837fc364bbfae05206495863.tar.gz
gentoo-c20eaf5374d83c9b837fc364bbfae05206495863.tar.bz2
gentoo-c20eaf5374d83c9b837fc364bbfae05206495863.zip
www-client/qutebrowser: EAPI7->8, migrate to xdg eclass, tidy a bit
Trying not to change too much here (unless I end up officially maintaining this), but removed some unnecessary quotes, add + to GPL-3 (as indicated in .py files), and cleanup python3.7 which wasn't usable anymore either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/qutebrowser-2.3.1.ebuild39
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild23
2 files changed, 24 insertions, 38 deletions
diff --git a/www-client/qutebrowser/qutebrowser-2.3.1.ebuild b/www-client/qutebrowser/qutebrowser-2.3.1.ebuild
index dd61b8b71581..e11338abf31f 100644
--- a/www-client/qutebrowser/qutebrowser-2.3.1.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.3.1.ebuild
@@ -1,24 +1,24 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..9} )
-inherit desktop distutils-r1 optfeature xdg-utils
+inherit desktop distutils-r1 optfeature xdg
-DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
+DESCRIPTION="Keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowser"
SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+adblock test"
BDEPEND="app-text/asciidoc"
RDEPEND=">=dev-python/colorama-0.4.4[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_{7,8})
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
>=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
>=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
@@ -53,7 +53,7 @@ python_install_all() {
doins misc/userscripts/README.md
exeinto /usr/share/qutebrowser/userscripts
for f in misc/userscripts/*; do
- if [[ "${f}" == "__pycache__" ]]; then
+ if [[ ${f} == __pycache__ ]]; then
continue
fi
doexe "${f}"
@@ -61,13 +61,13 @@ python_install_all() {
exeinto /usr/share/qutebrowser/scripts
for f in scripts/*; do
- if [[ "${f}" == "scripts/__init__.py" || \
- "${f}" == "scripts/__pycache__" || \
- "${f}" == "scripts/dev" || \
- "${f}" == "scripts/testbrowser" || \
- "${f}" == "scripts/asciidoc2html.py" || \
- "${f}" == "scripts/setupcommon.py" || \
- "${f}" == "scripts/link_pyqt.py" ]]; then
+ if [[ ${f} == scripts/__init__.py ||
+ ${f} == scripts/__pycache__ ||
+ ${f} == scripts/dev ||
+ ${f} == scripts/testbrowser ||
+ ${f} == scripts/asciidoc2html.py ||
+ ${f} == scripts/setupcommon.py ||
+ ${f} == scripts/link_pyqt.py ]]; then
continue
fi
doexe "${f}"
@@ -77,14 +77,7 @@ python_install_all() {
}
pkg_postinst() {
- optfeature "PDF display support" www-plugins/pdfjs
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
+ xdg_pkg_postinst
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
+ optfeature "PDF display support" www-plugins/pdfjs
}
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 8ed082ba920b..b9c6a309b372 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_USE_SETUPTOOLS="rdepend"
-inherit desktop distutils-r1 git-r3 optfeature xdg-utils
+inherit desktop distutils-r1 git-r3 optfeature xdg
-DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
+DESCRIPTION="Keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowser"
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
IUSE="scripts test"
@@ -22,7 +22,7 @@ RDEPEND="
dev-python/attrs[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/cssutils[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_{7,8})
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_8)
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/markupsafe[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
@@ -88,14 +88,7 @@ python_install_all() {
}
pkg_postinst() {
- optfeature "PDF display support" www-plugins/pdfjs
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
+ xdg_pkg_postinst
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
+ optfeature "PDF display support" www-plugins/pdfjs
}