summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-client/w3mmee
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-client/w3mmee')
-rw-r--r--www-client/w3mmee/Manifest1
-rw-r--r--www-client/w3mmee/files/w3mmee-0.3.2_p24-boehm-gc.patch13
-rw-r--r--www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch35
-rw-r--r--www-client/w3mmee/files/w3mmee-0.3.2_p24-tinfo.patch13
-rw-r--r--www-client/w3mmee/files/w3mmee-gcc44.patch12
-rw-r--r--www-client/w3mmee/files/w3mmee-gcc45.patch17
-rw-r--r--www-client/w3mmee/files/w3mmee-w3mman-gentoo.diff23
-rw-r--r--www-client/w3mmee/metadata.xml5
-rw-r--r--www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild155
9 files changed, 274 insertions, 0 deletions
diff --git a/www-client/w3mmee/Manifest b/www-client/w3mmee/Manifest
new file mode 100644
index 000000000000..baa192c54014
--- /dev/null
+++ b/www-client/w3mmee/Manifest
@@ -0,0 +1 @@
+DIST w3mmee-p24-22.tar.gz 690094 SHA256 1a905a30786568a2c607fd296ea7c13a03c6930d4b9fcb3d0e084c71e30aa665 SHA512 85d4d373a5a544f8c4fbc37e8344daaa5eae3ae007a0280c693aa8946c8cbf63f3fc92fb69c2597286921254e3234f29ee1b3f21e1c9d498b39a597a51e98761 WHIRLPOOL d4d3ba4ca690a2f41f2ce77292849fafbff320876b7e7df06ad599669d86b01762bd2036e8fcd7044545b5abd7345e02e0c172905f7306e073ac4cc98e1c9657
diff --git a/www-client/w3mmee/files/w3mmee-0.3.2_p24-boehm-gc.patch b/www-client/w3mmee/files/w3mmee-0.3.2_p24-boehm-gc.patch
new file mode 100644
index 000000000000..81e6a6dea0f3
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-0.3.2_p24-boehm-gc.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure
+index 32afb35..3be66fd 100755
+--- a/configure
++++ b/configure
+@@ -1503,7 +1503,7 @@ if [ -n "$gclib" -a -n "$gcinclude" ]; then
+ #include <gc.h>
+ main()
+ {
+- extern unsigned GC_version;
++ unsigned GC_version = GC_get_version();
+ printf("%d%02d%03d\n",(GC_version>>16)&0xff,(GC_version>>8)&0xff,GC_version&0xff);
+ }
+ EOF
diff --git a/www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch b/www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch
new file mode 100644
index 000000000000..dc9be94732c6
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-0.3.2_p24-glibc214.patch
@@ -0,0 +1,35 @@
+diff --git a/istream.c b/istream.c
+index de5fbd3..6718b41 100644
+--- a/istream.c
++++ b/istream.c
+@@ -132,7 +132,7 @@ newFileStream(FILE *f, void (*closep)())
+ stream = New(struct input_stream);
+ init_base_stream(stream, STREAM_BUF_SIZE);
+ stream->type = IST_FILE;
+- stream->handle.file = New(struct file_handle);
++ stream->handle.file = New(struct afile_handle);
+ stream->handle.file->f = f;
+
+ if (closep)
+diff --git a/istream.h b/istream.h
+index 168882f..3e7132f 100644
+--- a/istream.h
++++ b/istream.h
+@@ -20,7 +20,7 @@ struct stream_buffer {
+
+ typedef struct stream_buffer *StreamBuffer;
+
+-struct file_handle {
++struct afile_handle {
+ FILE *f;
+ void (*close)(FILE *);
+ };
+@@ -121,7 +121,7 @@ struct tee_handle {
+ union input_handle {
+ void *gen;
+ int fd;
+- struct file_handle *file;
++ struct afile_handle *file;
+ struct delimited_handle *delimited;
+ Str str;
+ #ifdef USE_SSL
diff --git a/www-client/w3mmee/files/w3mmee-0.3.2_p24-tinfo.patch b/www-client/w3mmee/files/w3mmee-0.3.2_p24-tinfo.patch
new file mode 100644
index 000000000000..603e30bb4038
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-0.3.2_p24-tinfo.patch
@@ -0,0 +1,13 @@
+diff --git a/configure b/configure
+index 73e247b..32afb35 100755
+--- a/configure
++++ b/configure
+@@ -1354,7 +1354,7 @@ main()
+ EOF
+
+ if [ -z "$dtermlib" ]; then
+- TERM_LIBS='termcap termlib terminfo mytinfo curses ncurses'
++ TERM_LIBS='termcap termlib terminfo mytinfo curses ncurses tinfo'
+
+ for lib in $TERM_LIBS; do
+ for tlibdir in /lib /usr/lib /usr/local/lib /usr/ucblib /usr/ccslib /usr/ccs/lib $prefix/lib; do
diff --git a/www-client/w3mmee/files/w3mmee-gcc44.patch b/www-client/w3mmee/files/w3mmee-gcc44.patch
new file mode 100644
index 000000000000..092adb5ba40c
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur w3mmee-p24-22.orig/indep.c w3mmee-p24-22/indep.c
+--- w3mmee-p24-22.orig/indep.c 2002-11-27 16:35:37.000000000 +0200
++++ w3mmee-p24-22/indep.c 2009-07-25 23:06:52.000000000 +0300
+@@ -14,7 +14,7 @@
+ {
+ #ifdef HAVE_STRTOLL
+ return strtoll(s, NULL, base);
+-#elif HAVE_STRTOQ
++#elif defined(HAVE_STRTOQ)
+ return strtoq(s, NULL, base);
+ #else
+ int minus, digit;
diff --git a/www-client/w3mmee/files/w3mmee-gcc45.patch b/www-client/w3mmee/files/w3mmee-gcc45.patch
new file mode 100644
index 000000000000..db6f86e4deee
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-gcc45.patch
@@ -0,0 +1,17 @@
+Fixing build with gcc-4.5
+
+https://bugs.gentoo.org/show_bug.cgi?id=317815
+
+Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
+
+--- configure
++++ configure
+@@ -2636,7 +2636,7 @@
+ fi
+
+ cat >do_mk_btri.sh <<END_OF_DO_MK_BTRI
+-$dcpp "\$1" | sed -n "/^[ ]*[\\"'%]/p" | $mk_btri_cmd
++$dcpp -P "\$1" | sed -n "/^[ ]*[\\"'%]/p" | $mk_btri_cmd
+ END_OF_DO_MK_BTRI
+
+ cat >TABMakefile <<END_OF_TABMAKEFILE1
diff --git a/www-client/w3mmee/files/w3mmee-w3mman-gentoo.diff b/www-client/w3mmee/files/w3mmee-w3mman-gentoo.diff
new file mode 100644
index 000000000000..967e679f02b2
--- /dev/null
+++ b/www-client/w3mmee/files/w3mmee-w3mman-gentoo.diff
@@ -0,0 +1,23 @@
+diff -urN w3mmee-p24-19.ORIG/scripts/w3mman/w3mman.in w3mmee-p24-19/scripts/w3mman/w3mman.in
+--- w3mmee-p24-19.ORIG/scripts/w3mman/w3mman.in 2002-03-17 14:07:08.000000000 +0900
++++ w3mmee-p24-19/scripts/w3mman/w3mman.in 2003-12-06 20:49:15.000000000 +0900
+@@ -1,7 +1,7 @@
+ #!@PERL@
+
+ @W3M = split(' ', '@W3M@');
+-$ENV{'MAN'} = '@MAN@';
++$ENV{'MAN'} = 'env LC_MESSAGES=${LC_MESSAGES:-${LC_ALL:-${LANG}}} LANG=C @MAN@';
+ $SCRIPT = 'file:///$LIB/w3mman2html.cgi';
+
+ sub usage {
+diff -urN w3mmee-p24-19.ORIG/scripts/w3mman/w3mman2html.cgi.in w3mmee-p24-19/scripts/w3mman/w3mman2html.cgi.in
+--- w3mmee-p24-19.ORIG/scripts/w3mman/w3mman2html.cgi.in 2002-03-17 14:07:08.000000000 +0900
++++ w3mmee-p24-19/scripts/w3mman/w3mman2html.cgi.in 2003-12-06 20:49:53.000000000 +0900
+@@ -1,6 +1,6 @@
+ #!@PERL@
+
+-$MAN = $ENV{'MAN'} || '@MAN@';
++$MAN = $ENV{'MAN'} || 'env LC_MESSAGES=${LC_MESSAGES:-${LC_ALL:-${LANG}}} LANG=C @MAN@';
+ $QUERY = $ENV{'QUERY_STRING'} || $ARGV[0];
+ $SCRIPT_NAME = $ENV{'SCRIPT_NAME'} || $0;
+ $CGI = "file://$SCRIPT_NAME";
diff --git a/www-client/w3mmee/metadata.xml b/www-client/w3mmee/metadata.xml
new file mode 100644
index 000000000000..2d5852c16c60
--- /dev/null
+++ b/www-client/w3mmee/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>
diff --git a/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild b/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
new file mode 100644
index 000000000000..fde62c6249e2
--- /dev/null
+++ b/www-client/w3mmee/w3mmee-0.3.2_p24-r7.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit alternatives eutils toolchain-funcs multilib
+
+IUSE="gpm imlib nls ssl xface"
+
+MY_PV=${PV##*_}-22
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="A variant of w3m with support for multiple character encodings"
+SRC_URI="http://pub.ks-and-ks.ne.jp/prog/pub/${MY_P}.tar.gz"
+HOMEPAGE="http://pub.ks-and-ks.ne.jp/prog/w3mmee/"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND=">=sys-libs/ncurses-5.2-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=dev-libs/boehm-gc-7.2
+ dev-lang/perl
+ >=dev-libs/libmoe-1.5.3
+ imlib? ( >=media-libs/imlib-1.9.8
+ xface? ( media-libs/compface ) )
+ gpm? ( >=sys-libs/gpm-1.19.3-r5 )
+ nls? ( sys-devel/gettext )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-w3mman-gentoo.diff \
+ "${FILESDIR}"/${PN}-gcc4{4,5}.patch \
+ "${FILESDIR}"/${P}-glibc214.patch \
+ "${FILESDIR}"/${P}-tinfo.patch \
+ "${FILESDIR}"/${P}-boehm-gc.patch
+ sed -ie "/^AR=/s:ar:$(tc-getAR):" XMakefile || die
+}
+
+src_compile() {
+
+ local myconf myuse
+ myuse="use_cookie=y use_ansi_color=y use_history=y
+ display_code=E system_code=E"
+
+ if use ssl ; then
+ myconf="${myconf} --ssl-includedir=/usr/include/openssl
+ --ssl-libdir=/usr/$(get_libdir)"
+ myuse="${myuse} use_ssl=y use_ssl_verify=y use_digest_auth=y"
+ else
+ myuse="${myuse} use_ssl=n"
+ fi
+
+ if use gpm ; then
+ myuse="${myuse} use_mouse=y"
+ else
+ myuse="${myuse} use_mouse=n"
+ fi
+
+ if use nls ; then
+ myconf="${myconf} -locale_dir=/usr/share/locale"
+ else
+ myconf="${myconf} -locale_dir='(NONE)'"
+ fi
+
+ if use imlib ; then
+ myuse="${myuse} use_image=y use_w3mimg_x11=y
+ use_w3mimg_fb=n w3mimgdisplay_setuid=n"
+ if use xface ; then
+ myuse="${myuse} use_xface=y"
+ else
+ myuse="${myuse} use_xface=n"
+ fi
+ else
+ myuse="${myuse} use_image=n"
+ fi
+
+ cat >>config.param<<-EOF
+ lang=MANY
+ accept_lang=en
+ EOF
+
+ env CC=$(tc-getCC) ${myuse} ./configure -nonstop \
+ -prefix=/usr \
+ -suffix=mee \
+ -auxbindir=/usr/$(get_libdir)/w3mmee \
+ -libdir=/usr/$(get_libdir)/w3mmee/cgi-bin \
+ -helpdir=/usr/share/w3mmee \
+ -mandir=/usr/share/man \
+ -sysconfdir=/etc/w3mmee \
+ -model=custom \
+ -libmoe=/usr/$(get_libdir) \
+ -mb_h=/usr/include/moe \
+ -mk_btri=/usr/libexec/moe \
+ -cflags="${CFLAGS}" -ldflags="${LDFLAGS}" \
+ ${myconf} || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # w3mman and manpages conflict with those from w3m
+ mv "${D}"/usr/share/man/ja/man1/w3m{,mee}.1 || die
+ mv "${D}"/usr/share/man/man1/w3m{,mee}.1 || die
+
+ dodoc ChangeLog NEWS* README
+ dohtml 00INCOMPATIBLE.html
+
+ docinto en
+ dodoc doc/HISTORY doc/README* doc/keymap.* doc/menu.*
+ dohtml doc/*
+
+ docinto jp
+ dodoc doc-jp/HISTORY doc-jp/README* doc-jp/keymap* doc-jp/menu.*
+ dohtml doc-jp/*
+}
+
+pkg_postinst() {
+
+ w3m_alternatives
+ einfo
+ einfo "If you want to render multilingual text, please refer to"
+ einfo "/usr/share/doc/${PF}/en/README.mee or"
+ einfo "/usr/share/doc/${PF}/jp/README.mee"
+ einfo "and set W3MLANG variable respectively."
+ einfo
+}
+
+pkg_postrm() {
+
+ w3m_alternatives
+}
+
+w3m_alternatives() {
+
+ if [ ! -f /usr/bin/w3m ] ; then
+ alternatives_makesym /usr/bin/w3m \
+ /usr/bin/w3m{m17n,mee}
+ alternatives_makesym /usr/bin/w3mman \
+ /usr/bin/w3m{man-m17n,meeman}
+ alternatives_makesym /usr/share/man/ja/man1/w3m.1.gz \
+ /usr/share/man/ja/man1/w3m{m17n,mee}.1.gz
+ alternatives_makesym /usr/share/man/man1/w3m.1.gz \
+ /usr/share/man/man1/w3m{m17n,mee}.1.gz
+ alternatives_makesym /usr/share/man/man1/w3mman.1.gz \
+ /usr/share/man/man1/w3m{man-m17n,meeman}.1.gz
+ fi
+}