summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2019-12-07 18:41:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-12-12 19:53:34 +0200
commitb7b0b24dae7d9a0f8b5a8447a3901560d6184040 (patch)
tree30d9c9cb08214b7257eba2c1a8f377239d4143ef /www-apps/gitea/gitea-9999.ebuild
parentwww-apps/davical: remove vulnerable versions (diff)
downloadgentoo-b7b0b24dae7d9a0f8b5a8447a3901560d6184040.tar.gz
gentoo-b7b0b24dae7d9a0f8b5a8447a3901560d6184040.tar.bz2
gentoo-b7b0b24dae7d9a0f8b5a8447a3901560d6184040.zip
www-apps/gitea: bump to 1.10.1
Closes: https://bugs.gentoo.org/689748 Closes: https://bugs.gentoo.org/702192 Package-Manager: Portage-2.3.80, Repoman-2.3.20 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-apps/gitea/gitea-9999.ebuild')
-rw-r--r--www-apps/gitea/gitea-9999.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/www-apps/gitea/gitea-9999.ebuild b/www-apps/gitea/gitea-9999.ebuild
index 1fd7feaaff4c..9e8bcf9c6054 100644
--- a/www-apps/gitea/gitea-9999.ebuild
+++ b/www-apps/gitea/gitea-9999.ebuild
@@ -43,17 +43,24 @@ DOCS=( custom/conf/app.ini.sample CONTRIBUTING.md README.md )
S="${WORKDIR}/${P}/src/${EGO_PN}"
gitea_make() {
- local my_tags=(
+ local gitea_tags=(
bindata
$(usev pam)
$(usex sqlite 'sqlite sqlite_unlock_notify' '')
)
- local my_makeopt=(
- TAGS="${my_tags[@]}"
- LDFLAGS="-extldflags \"${LDFLAGS}\""
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
)
- [[ ${PV} != 9999* ]] && my_makeopt+=("DRONE_TAG=${PV}")
- GOPATH=${WORKDIR}/${P}:$(get_golibdir_gopath) emake "${my_makeopt[@]}" "$@"
+ local makeenv=(
+ TAGS="${gitea_tags[@]}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[@]}"
+ GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)"
+ )
+ [[ ${PV} != 9999* ]] && makeenv+=("DRONE_TAG=${PV}")
+
+ env "${makeenv[@]}" emake "$@"
}
src_prepare() {
@@ -88,13 +95,13 @@ src_compile() {
src_test() {
if has network-sandbox ${FEATURES}; then
einfo "Remove tests which are known to fail with network-sandbox enabled."
- rm -rf ./modules/migrations/github_test.go
+ rm ./modules/migrations/github_test.go || die
fi
if [[ ${PV} != 9999* ]] ; then
einfo "Remove tests which depend on gitea git-repo."
- rm -rf ./modules/git/blob_test.go
- rm -rf ./modules/git/repo_test.go
+ rm ./modules/git/blob_test.go || die
+ rm ./modules/git/repo_test.go || die
fi
default