summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_xml2enc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_xml2enc')
-rw-r--r--www-apache/mod_xml2enc/Manifest2
-rw-r--r--www-apache/mod_xml2enc/metadata.xml7
-rw-r--r--www-apache/mod_xml2enc/mod_xml2enc-1.0.3.ebuild38
3 files changed, 47 insertions, 0 deletions
diff --git a/www-apache/mod_xml2enc/Manifest b/www-apache/mod_xml2enc/Manifest
new file mode 100644
index 000000000000..61b411dfa8eb
--- /dev/null
+++ b/www-apache/mod_xml2enc/Manifest
@@ -0,0 +1,2 @@
+DIST mod_xml2enc.c 22380 SHA256 54d2d82c54f60e73eaddb69c00d2fd7be1786c449d5c7bbe045b30e56d19ba24 SHA512 b38d81ff419e9c00e302eb555715181cf2157af2d15a15b86d34f948c0c2f55de237234a24140b9fc2c1d3d46d688c4e9c4ab74af34b451677224a30b1b08582 WHIRLPOOL 6c925558f56f3f4c934ab6b50f055bac15eaf09a837500aae900d9c451ab357bc53f0d1c44759f4eb66f5c17d91a46f64cd9467c7a50d2dd8aa6d812bc2340d2
+DIST mod_xml2enc.h 1479 SHA256 3a4106a2de484812b6c98aa0845333be83e5f659eebe37678986b8829ee3d4a9 SHA512 01961c3f788ad4a53c2c8f4d9ddebb0333e75b8589df0ab0eb80b53ce781fa5d34b7908d082feeedc7d8a8582a8b798af26b9af107423dad99b83df5c6d5e7d3 WHIRLPOOL 539350c39c7198240cd7eabd43c3bce26d15456064b6dd68757fa70001072b1161acd388913a7941f367e56dcb00cf01bcc442d8da206ce1b2d54cbc7bcd99bf
diff --git a/www-apache/mod_xml2enc/metadata.xml b/www-apache/mod_xml2enc/metadata.xml
new file mode 100644
index 000000000000..2d6c34cc4459
--- /dev/null
+++ b/www-apache/mod_xml2enc/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_xml2enc/mod_xml2enc-1.0.3.ebuild b/www-apache/mod_xml2enc/mod_xml2enc-1.0.3.ebuild
new file mode 100644
index 000000000000..180dd15efca1
--- /dev/null
+++ b/www-apache/mod_xml2enc/mod_xml2enc-1.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit apache-module
+
+DESCRIPTION="An Apache2 module to provide libxml2 encoding"
+HOMEPAGE="http://apache.webthing.com/mod_xml2enc/"
+SRC_URI="http://apache.webthing.com/svn/apache/filters/mod_xml2enc.h
+ http://apache.webthing.com/svn/apache/filters/mod_xml2enc.c"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/bzip2
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+#APACHE2_MOD_CONF="27_${PN}"
+#APACHE2_MOD_DEFINE="XML2ENC"
+
+need_apache2
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ mkdir "${WORKDIR}"/${PN}
+ cp "${DISTDIR}/mod_xml2enc.h" "${WORKDIR}"/${PN}
+ cp "${DISTDIR}/mod_xml2enc.c" "${WORKDIR}"/${PN}
+}
+
+src_compile() {
+ APXS2_ARGS="$(xml2-config --cflags) -c ${PN}.c"
+ apache-module_src_compile
+}