summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-11-13 15:31:10 -0500
committerCraig Andrews <candrews@gentoo.org>2020-11-13 15:34:00 -0500
commitd9734e30be85536294512927681f0ec63436934e (patch)
tree197dd98a85364836ff3d5fdbf2a81667b7af2f03 /www-apache/mod_qos/mod_qos-11.66.ebuild
parentmail-mta/msmtp: Removed old (diff)
downloadgentoo-d9734e30be85536294512927681f0ec63436934e.tar.gz
gentoo-d9734e30be85536294512927681f0ec63436934e.tar.bz2
gentoo-d9734e30be85536294512927681f0ec63436934e.zip
www-apache/mod_qos: 11.66 version bump
Closes: https://bugs.gentoo.org/748969 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_qos/mod_qos-11.66.ebuild')
-rw-r--r--www-apache/mod_qos/mod_qos-11.66.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-apache/mod_qos/mod_qos-11.66.ebuild b/www-apache/mod_qos/mod_qos-11.66.ebuild
new file mode 100644
index 000000000000..5a36fe7b7c06
--- /dev/null
+++ b/www-apache/mod_qos/mod_qos-11.66.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools apache-module
+
+DESCRIPTION="A QOS module for the apache webserver"
+HOMEPAGE="http://mod-qos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libpcre:3
+ dev-libs/openssl:0=
+ media-libs/libpng:0=
+ sys-libs/zlib:0=
+"
+DEPEND="${DEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="QOS"
+DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
+
+need_apache2
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+src_prepare() {
+ default
+
+ pushd "${S}"/tools &>/dev/null || die
+ eautoreconf
+ popd &>/dev/null || die
+}
+
+src_configure() {
+ pushd "${S}"/tools &>/dev/null || die
+ econf
+ popd &>/dev/null || die
+}
+
+src_compile() {
+ apache-module_src_compile
+ emake -C "${S}"/tools
+}
+
+src_install() {
+ einfo "Installing Apache module ..."
+ pushd "${S}"/tools &>/dev/null || die
+ apache-module_src_install
+ popd &>/dev/null || die
+
+ einfo "Installing module utilities ..."
+ emake -C "${S}"/tools install DESTDIR="${D}"
+}