summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-12-19 22:37:14 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-12-19 23:08:00 -0800
commit81299f61a075eccc49e51235f47b84851c26a242 (patch)
tree55f3e02d44a4b26ec0a0dbcf491ac8c38605e168 /virtual/rust
parentdev-lang/rust: add 1.66.0 (diff)
downloadgentoo-81299f61a075eccc49e51235f47b84851c26a242.tar.gz
gentoo-81299f61a075eccc49e51235f47b84851c26a242.tar.bz2
gentoo-81299f61a075eccc49e51235f47b84851c26a242.zip
virtual/rust: add 1.66.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.66.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.66.0.ebuild b/virtual/rust/rust-1.66.0.ebuild
new file mode 100644
index 000000000000..546e918affb9
--- /dev/null
+++ b/virtual/rust/rust-1.66.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-15"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"