summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-10-01 20:34:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-10-01 21:01:59 +0300
commit765e2f99d8de7bcd70b407b58e565c236f0c6b39 (patch)
tree102f60c4e4d70859c53326dc1254376ebaad3e42 /sys-process
parentsys-firmware/sof-firmware: drop 2.2.4, 2.2.5 (diff)
downloadgentoo-765e2f99d8de7bcd70b407b58e565c236f0c6b39.tar.gz
gentoo-765e2f99d8de7bcd70b407b58e565c236f0c6b39.tar.bz2
gentoo-765e2f99d8de7bcd70b407b58e565c236f0c6b39.zip
sys-process/iotop-c: add 1.24
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/iotop-c/Manifest1
-rw-r--r--sys-process/iotop-c/iotop-c-1.24.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
index f7d8388fe7b4..abfc5bac5c2f 100644
--- a/sys-process/iotop-c/Manifest
+++ b/sys-process/iotop-c/Manifest
@@ -1 +1,2 @@
DIST iotop-c-1.23.tar.gz 138772 BLAKE2B 123995c5af48f2d257a4c4b2f342c3cb656d91105e13200baac63c3bd5bdd68a09cf4991363db4d49b211f0ad75285b3f34e66951aa80b2df55f6728c54629dc SHA512 afdc59373e96f23efaf93a661ca31d101732b36e61631844864692599b0e5a1d2355fdda0ec994a8e9ed03bc7f6a37c4dd16336fb750084294d58bfcfc6e7f17
+DIST iotop-c-1.24.tar.gz 139533 BLAKE2B 4946876d474750e76ada3f1faa6057b02482f90b917663918669e40ad403c12c90add931c958f868b1b5f4cf1f9c980109795f4322e0db34c84f24f7299b7065 SHA512 4ff78f689ad0734787bfa0bc909a261694b75175301b3f732c170bf8511bab60082a2b363198057ef04b258fe3f4d24e081521f1f4eee6708b595e6a5f80ef2c
diff --git a/sys-process/iotop-c/iotop-c-1.24.ebuild b/sys-process/iotop-c/iotop-c-1.24.ebuild
new file mode 100644
index 000000000000..9803d2a23784
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.24.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ !sys-process/iotop
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}