summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-25 21:22:30 +0000
committerSam James <sam@gentoo.org>2022-12-25 21:24:12 +0000
commit669674443447ac910a730a963877cd949320a9db (patch)
treefff854a643f96e4e2c03dc89d833d411a4da9894 /sys-process
parentsys-block/qla-fc-firmware: EAPI 8 (diff)
downloadgentoo-669674443447ac910a730a963877cd949320a9db.tar.gz
gentoo-669674443447ac910a730a963877cd949320a9db.tar.bz2
gentoo-669674443447ac910a730a963877cd949320a9db.zip
sys-process/daemontools-encore: EAPI 8, fix build w/ Clang 16
Closes: https://bugs.gentoo.org/870949 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/daemontools-encore/daemontools-encore-1.11-r1.ebuild (renamed from sys-process/daemontools-encore/daemontools-encore-1.11.ebuild)14
-rw-r--r--sys-process/daemontools-encore/files/daemontools-encore-1.11-implicit-func-decl-clang16.patch13
2 files changed, 21 insertions, 6 deletions
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.11.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.11-r1.ebuild
index 9c5f7b2a5230..7cb3f795fc2d 100644
--- a/sys-process/daemontools-encore/daemontools-encore-1.11.ebuild
+++ b/sys-process/daemontools-encore/daemontools-encore-1.11-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit flag-o-matic qmail
@@ -14,14 +14,16 @@ SLOT="0"
KEYWORDS="~amd64 ~loong ~x86"
IUSE="selinux static"
-DEPEND=""
-RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+RDEPEND="
+ !app-doc/daemontools-man
!sys-process/daemontools
- !app-doc/daemontools-man"
+ selinux? ( sec-policy/selinux-daemontools )
+"
PATCHES=(
"${FILESDIR}"/${PN}-1.11-do-not-always-run-tests.patch
"${FILESDIR}"/${PN}-1.11-add-missing-setuser-man-page.patch
+ "${FILESDIR}"/${PN}-1.11-implicit-func-decl-clang16.patch
)
src_compile() {
@@ -33,8 +35,8 @@ src_compile() {
src_install() {
keepdir /service
- echo "${ED%/}/usr/bin" >conf-bin
- echo "${ED%/}/usr/share/man" >conf-man
+ echo "${ED}/usr/bin" > conf-bin || die
+ echo "${ED}/usr/share/man" > conf-man || die
dodir /usr/bin
dodir /usr/share/man
emake install
diff --git a/sys-process/daemontools-encore/files/daemontools-encore-1.11-implicit-func-decl-clang16.patch b/sys-process/daemontools-encore/files/daemontools-encore-1.11-implicit-func-decl-clang16.patch
new file mode 100644
index 000000000000..35bcb5833ddc
--- /dev/null
+++ b/sys-process/daemontools-encore/files/daemontools-encore-1.11-implicit-func-decl-clang16.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/870949
+--- a/sig_pause.c
++++ b/sig_pause.c
+@@ -1,5 +1,9 @@
+ /* Public domain. */
+
++#ifndef _XOPEN_SOURCE
++#define _XOPEN_SOURCE 500
++#endif
++
+ #include <signal.h>
+ #include "sig.h"
+ #include "hassgprm.h"