summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-11 22:12:13 +0100
committerSam James <sam@gentoo.org>2024-08-11 22:14:21 +0100
commit64c0eea4331717f129cfb1f4d333b56e9c24de4b (patch)
tree0b588478565ea8c04213df51eb0f5c1f50f4f5d6 /sys-process
parentsys-process/atop: tweak PKG_CONFIG patch (diff)
downloadgentoo-64c0eea4331717f129cfb1f4d333b56e9c24de4b.tar.gz
gentoo-64c0eea4331717f129cfb1f4d333b56e9c24de4b.tar.bz2
gentoo-64c0eea4331717f129cfb1f4d333b56e9c24de4b.zip
sys-process/atop: add 2.11.0
Closes: https://bugs.gentoo.org/931632 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/atop/Manifest2
-rw-r--r--sys-process/atop/atop-2.11.0.ebuild117
-rw-r--r--sys-process/atop/files/atop-2.11.0-build.patch35
-rw-r--r--sys-process/atop/files/atop-2.11.0-respect-opt.patch11
4 files changed, 165 insertions, 0 deletions
diff --git a/sys-process/atop/Manifest b/sys-process/atop/Manifest
index abd98674fa7a..5df7b243b145 100644
--- a/sys-process/atop/Manifest
+++ b/sys-process/atop/Manifest
@@ -1,3 +1,5 @@
DIST atop-2.10.0.tar.gz 296569 BLAKE2B 8c6e56978cb32e4e80c7344f631d6fd3dd034ff785e6b2db1b80556aaea30a0feeb413704128150ba0d7b1b4eaeb6cb5699a1b2661060ac53c10f7025997418e SHA512 22e39799aa7c090c68d8ac2f02646fb9586122bdb83de9d90bc3119bd290c557faa0489cdc8640fc4fd1f1155c231b1d70dae1b22dc6102ba0327fdd4b5f7029
+DIST atop-2.11.0.tar.gz 322301 BLAKE2B 0084f1c02e835abd69c4810c0ef020d40bd8738064f8b9ae3cb1f24c460507571b87ddf47f12a0b2eefa86f9d0dcce02be8829e157dcc289deaac6d9cd3c7cda SHA512 5cf176e83232a54b69628b165172ed43f7bdfb62c7744ee781da8a262f3e4d70a829dc175320b5042a794a8d31318672477ba870feaaf3e9aa85fd4d6f485356
DIST atop-2.9.0.tar.gz 282412 BLAKE2B 8531eee3bffabfb3cacdb6bea4c4a1b7ea56da878154a86edd80fb20ddffc5f56248d06c679bd8933c203a0174e97515cfce633a2387bf465399d4203ca857c2 SHA512 f055466c076491a54fc45a482209fd3de60013e7b76af46b65dffe82d220fbd96eb11d5f199aa27e2f7a8754fe3c6509c44bf0dbd6e3099d8f5710944e01cb38
DIST netatop-3.1.tar.gz 22812 BLAKE2B 1b1faebf1392a57db6b4662192f90821289c8fc40c2c1ee0ad61feeeee6477c4d091744a1e82cdd987baf59f8dd71fc6d242d6dd294b8fb29b9447a9d5055996 SHA512 b12fd2287d89d3a8277f8fb540a19e6d26aa26c3f88e7ae2e6601b63f78d642e73b8d16cf351f6979ce7bbf53251b9c1faa76798a87f70cf3dcf51279eb0db68
+DIST netatop-3.2.2.tar.gz 23977 BLAKE2B cf360071e56593251df4249d2c7ec8a1c823c71a4d96e5b7f5d02ab0dc8388eb22d34c4120924c5a5ecc9b4d610a14785e5002bc3b888aa4c66d8c73454a0900 SHA512 59ff6daf56f73578cfc7b48085747d3f2917589203196396dde6036c33da0dbce4b67b58c141545a785beb31ebeb35936d96bb6ff3b6071e95315a32e20d6093
diff --git a/sys-process/atop/atop-2.11.0.ebuild b/sys-process/atop/atop-2.11.0.ebuild
new file mode 100644
index 000000000000..547074271ffe
--- /dev/null
+++ b/sys-process/atop/atop-2.11.0.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check on bumps of atop
+# https://www.atoptool.nl/downloadnetatop.php
+NETATOP_VER=3.2.2
+
+# Controls 'netatop' kernel module
+MODULES_OPTIONAL_IUSE="modules"
+NETATOP_P=netatop-${NETATOP_VER}
+NETATOP_S="${WORKDIR}"/${NETATOP_P}
+
+inherit linux-mod-r1 systemd toolchain-funcs
+
+DESCRIPTION="Resource-specific view of processes"
+HOMEPAGE="https://www.atoptool.nl/ https://github.com/Atoptool/atop"
+SRC_URI="https://github.com/Atoptool/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" modules? ( https://www.atoptool.nl/download/${NETATOP_P}.tar.gz )"
+
+# Module is GPL-2 as well
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-libs/glib
+ sys-libs/ncurses:=
+ sys-libs/zlib
+ >=sys-process/acct-6.6.4-r1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.11.0-build.patch
+ "${FILESDIR}"/${PN}-2.11.0-respect-opt.patch
+)
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ CONFIG_CHECK="~BSD_PROCESS_ACCT"
+ check_extra_config
+ fi
+}
+
+src_prepare() {
+ default
+
+ if use modules ; then
+ cd "${WORKDIR}"/${NETATOP_P} || die
+
+ sed \
+ -e "s#\`uname -r\`#${KV_FULL}#g" \
+ -e "s#\$(shell uname -r)#${KV_FULL}#g" \
+ -i Makefile || die
+
+ grep -rq "uname -r" && die "found uname calls"
+
+ cd "${S}" || die
+ fi
+
+ tc-export CC PKG_CONFIG
+
+ # bug #191926
+ sed -i 's: root : :' atop.cronsysv || die
+
+ # Prefixify
+ sed -i "s:/\(usr\|etc\|var\):${EPREFIX}/\1:g" Makefile || die
+}
+
+src_compile() {
+ default
+
+ local modlist=( "netatop=:../${NETATOP_P}::netatop.ko" )
+ linux-mod-r1_src_compile
+
+ if use modules ; then
+ # Don't let the Makefile try to build the module for us
+ emake -C "${NETATOP_S}" netatopd
+ fi
+}
+
+src_install() {
+ linux-mod-r1_src_install
+
+ if use modules ; then
+ dosbin "${NETATOP_S}"/netatopd
+ doman "${NETATOP_S}"/man/*
+
+ systemd_dounit "${NETATOP_S}"/netatop.service
+
+ newinitd "${NETATOP_S}"/netatop.rc netatop
+ fi
+
+ emake DESTDIR="${D}" genericinstall
+
+ # useless -${PV} copies ?
+ rm "${ED}"/usr/bin/atop*-${PV} || die
+
+ newinitd atop.rc.openrc ${PN}
+ newinitd atopacct.rc.openrc atopacct
+
+ systemd_dounit "${S}"/${PN}.service
+ systemd_dounit "${S}"/atopacct.service
+
+ dodoc atop.cronsysv AUTHORS README
+
+ exeinto /usr/share/${PN}
+ doexe ${PN}.daily
+
+ insinto /etc/default
+ newins ${PN}{.default,}
+
+ keepdir /var/log/${PN}
+}
diff --git a/sys-process/atop/files/atop-2.11.0-build.patch b/sys-process/atop/files/atop-2.11.0-build.patch
new file mode 100644
index 000000000000..37d262a553f9
--- /dev/null
+++ b/sys-process/atop/files/atop-2.11.0-build.patch
@@ -0,0 +1,35 @@
+From 26a85b778ecf45989347ddee256af65f9b26747d Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 11 Aug 2024 22:04:15 +0100
+Subject: [PATCH] foo
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/Makefile
++++ b/Makefile
+@@ -35,19 +35,19 @@ VERS = $(shell ./atop -V 2>/dev/null| sed -e 's/^[^ ]* //' -e 's/ .*//')
+ all: atop atopsar atopacctd atopconvert atopcat atophide
+
+ atop: atop.o $(ALLMODS) Makefile
+- $(CC) atop.o $(ALLMODS) -o atop -lncursesw -lz -lm -lrt $(LDFLAGS)
++ $(CC) $(CFLAGS) atop.o $(ALLMODS) -o atop $(shell ${PKG_CONFIG} --libs ncurses) -lz -lm -lrt $(LDFLAGS)
+
+ atopsar: atop
+ ln -sf atop atopsar
+
+ atopacctd: atopacctd.o netlink.o
+- $(CC) atopacctd.o netlink.o -o atopacctd $(LDFLAGS)
++ $(CC) $(CFLAGS) atopacctd.o netlink.o -o atopacctd $(LDFLAGS)
+
+ atopconvert: atopconvert.o
+- $(CC) atopconvert.o -o atopconvert -lz $(LDFLAGS)
++ $(CC) $(CFLAGS) atopconvert.o -o atopconvert -lz $(LDFLAGS)
+
+ atopcat: atopcat.o
+- $(CC) atopcat.o -o atopcat $(LDFLAGS)
++ $(CC) $(CFLAGS) atopcat.o -o atopcat $(LDFLAGS)
+
+ atophide: atophide.o
+ $(CC) atophide.o -o atophide -lz $(LDFLAGS)
+--
+2.45.2
+
diff --git a/sys-process/atop/files/atop-2.11.0-respect-opt.patch b/sys-process/atop/files/atop-2.11.0-respect-opt.patch
new file mode 100644
index 000000000000..e768299c011a
--- /dev/null
+++ b/sys-process/atop/files/atop-2.11.0-respect-opt.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -21,7 +21,7 @@ PMPATH2 = /usr/lib64/pm-utils/sleep.d
+ PMPATHD = /usr/lib/systemd/system-sleep
+
+ PKG_CONFIG ?= pkg-config
+-CFLAGS += -O2 -I. -Wall $(shell $(PKG_CONFIG) --cflags glib-2.0) -Wno-stringop-truncation -Wmissing-prototypes -Wmissing-declarations -Wformat-security # -DNOPERFEVENT # -DHTTPSTATS
++CFLAGS += -I. -Wall $(shell $(PKG_CONFIG) --cflags glib-2.0) -Wno-stringop-truncation -Wmissing-prototypes -Wmissing-declarations -Wformat-security # -DNOPERFEVENT # -DHTTPSTATS
+ LDFLAGS += $(shell $(PKG_CONFIG) --libs glib-2.0)
+ OBJMOD0 = version.o
+ OBJMOD1 = various.o deviate.o procdbase.o