summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2024-06-07 09:21:02 -0400
committerKenton Groombridge <concord@gentoo.org>2024-06-07 09:27:03 -0400
commit5139c6dacff4d358f9313de8a43d9fe8fc027bb8 (patch)
treee263f1f6daf8ee8120c3c944597f579bc9e3584f /sys-process
parentapp-editors/nano: Stabilize 8.0 ppc, #933698 (diff)
downloadgentoo-5139c6dacff4d358f9313de8a43d9fe8fc027bb8.tar.gz
gentoo-5139c6dacff4d358f9313de8a43d9fe8fc027bb8.tar.bz2
gentoo-5139c6dacff4d358f9313de8a43d9fe8fc027bb8.zip
sys-process/audit: add missing BDEPEND for setuptools
With python3.12, distutils isn't included with the interpreter but is instead bundled in setuptools. Add a conditional dependency for it when python3.12 is enabled. Closes: https://bugs.gentoo.org/933726 Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/audit-3.1.1.ebuild8
-rw-r--r--sys-process/audit/audit-3.1.2.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/sys-process/audit/audit-3.1.1.ebuild b/sys-process/audit/audit-3.1.1.ebuild
index 347a7e71e862..97910e182b7e 100644
--- a/sys-process/audit/audit-3.1.1.ebuild
+++ b/sys-process/audit/audit-3.1.1.ebuild
@@ -34,7 +34,13 @@ DEPEND="
>=sys-kernel/linux-headers-2.6.34
test? ( dev-libs/check )
"
-BDEPEND="python? ( dev-lang/swig )"
+BDEPEND="python? (
+ dev-lang/swig
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' python3_12)
+ )
+"
CONFIG_CHECK="~AUDIT"
diff --git a/sys-process/audit/audit-3.1.2.ebuild b/sys-process/audit/audit-3.1.2.ebuild
index b4be6f0deebc..a01ceddb51ff 100644
--- a/sys-process/audit/audit-3.1.2.ebuild
+++ b/sys-process/audit/audit-3.1.2.ebuild
@@ -34,7 +34,13 @@ DEPEND="
>=sys-kernel/linux-headers-2.6.34
test? ( dev-libs/check )
"
-BDEPEND="python? ( dev-lang/swig )"
+BDEPEND="python? (
+ dev-lang/swig
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ' python3_12)
+ )
+"
CONFIG_CHECK="~AUDIT"