summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-21 07:47:30 +0000
committerSam James <sam@gentoo.org>2024-02-21 07:53:02 +0000
commit214868f4efb71f25d792d6d2254f5cad8a62c7f1 (patch)
treed7f8aeed999068a53003497a488f23571d326b51 /sys-process
parentsys-apps/ed: add 1.20.1 (diff)
downloadgentoo-214868f4efb71f25d792d6d2254f5cad8a62c7f1.tar.gz
gentoo-214868f4efb71f25d792d6d2254f5cad8a62c7f1.tar.bz2
gentoo-214868f4efb71f25d792d6d2254f5cad8a62c7f1.zip
sys-process/numactl: drop 2.0.14, 2.0.14-r1, 2.0.16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/Manifest1
-rw-r--r--sys-process/numactl/files/numactl-2.0.14-latomic.patch50
-rw-r--r--sys-process/numactl/numactl-2.0.14-r1.ebuild76
-rw-r--r--sys-process/numactl/numactl-2.0.14.ebuild71
-rw-r--r--sys-process/numactl/numactl-2.0.16.ebuild67
5 files changed, 0 insertions, 265 deletions
diff --git a/sys-process/numactl/Manifest b/sys-process/numactl/Manifest
index 291aeb4b2047..1c6384c9de51 100644
--- a/sys-process/numactl/Manifest
+++ b/sys-process/numactl/Manifest
@@ -1,2 +1 @@
-DIST numactl-2.0.14.tar.gz 439000 BLAKE2B 5f2abe25061ac29ecad8a6b24fe800d72c3538d9a155358f4b329ed1140053c7dbd93f01891904f76db94ed01113a34b4ebcbbf40e4060caf747958785ac9590 SHA512 28b95985d6b2f26c5f6f15fe235224c998c86f534adf5fdaa355a292cf2fd65515c91ba2a76c899d552d439b18ea1209a1712bd6755f8ee3a442f3935993b2e6
DIST numactl-2.0.16.tar.gz 450003 BLAKE2B 3ac38129b914d62958182020f57969878f2817bd3155c6b5362a66f96deb2058268fa8004729a2d3333642c8c0bee73a451030a287958fa145247b7685e426aa SHA512 6e17724567c363a08994fe7f5569b6ec62bd1ae608244945fddcb2d6a212b08140340f0d862595ba4016fcba95193e851cb286798f685d314b4c72687af6d879
diff --git a/sys-process/numactl/files/numactl-2.0.14-latomic.patch b/sys-process/numactl/files/numactl-2.0.14-latomic.patch
deleted file mode 100644
index 61655f409967..000000000000
--- a/sys-process/numactl/files/numactl-2.0.14-latomic.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From e0de0d9e981ddb53bdeb4a4b9dc43046c9ff4ff9 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Thu, 6 May 2021 23:08:36 +0200
-Subject: [PATCH] link with -latomic if needed
-
-numactl unconditionally uses __atomic_fetch_and but some architectures
-(e.g. sparc) needs to link with -latomic to be able to use it. So check
-if -latomic is needed and update numa.pc accordingly
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
----
- Makefile.am | 1 +
- configure.ac | 2 ++
- numa.pc.in | 1 +
- 3 files changed, 4 insertions(+)
-
-diff --git a/Makefile.am b/Makefile.am
-index 44d0d76..34f6815 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -151,6 +151,7 @@ SED_PROCESS = \
- -e 's,@exec_prefix\@,$(exec_prefix),g' \
- -e 's,@libdir\@,$(libdir),g' \
- -e 's,@includedir\@,$(includedir),g' \
-+ -e 's,@LIBS\@,$(LIBS),g' \
- < $< > $@ || rm $@
-
- %.pc: %.pc.in Makefile
-diff --git a/configure.ac b/configure.ac
-index 659a765..e3b0eb3 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -24,6 +24,8 @@ AM_CONDITIONAL([HAVE_TREE_VECTORIZE], [test x"${tree_vectorize}" = x"true"])
-
- AC_CONFIG_FILES([Makefile])
-
-+AC_SEARCH_LIBS([__atomic_fetch_and_1], [atomic])
-+
- # GCC tries to be "helpful" and only issue a warning for unrecognized
- # attributes. So we compile the test with Werror, so that if the
- # attribute is not recognized the compilation fails
-diff --git a/numa.pc.in b/numa.pc.in
-index 8a0f202..cc04d50 100644
---- a/numa.pc.in
-+++ b/numa.pc.in
-@@ -8,3 +8,4 @@ Description: NUMA policy library
- Version: @VERSION@
- Cflags: -I${includedir}
- Libs: -L${libdir} -lnuma
-+Libs.Private: @LIBS@
diff --git a/sys-process/numactl/numactl-2.0.14-r1.ebuild b/sys-process/numactl/numactl-2.0.14-r1.ebuild
deleted file mode 100644
index 7cbcd6f6a72d..000000000000
--- a/sys-process/numactl/numactl-2.0.14-r1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} != 2.0.14 ]] ; then
- eerror "Please do not bump to 2.0.15! It's broken:"
- eerror "https://github.com/numactl/numactl/issues/135"
- eerror "It's also missing a dist tarball:"
- eerror "https://github.com/numactl/numactl/issues/140"
- die "Please check ebuild!"
-fi
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="Utilities and libraries for NUMA systems"
-HOMEPAGE="https://github.com/numactl/numactl"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/numactl/numactl.git"
-else
- SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.14-latomic.patch
- "${FILESDIR}"/${PN}-2.0.14-numademo-cflags.patch # bug #540856
-)
-
-src_prepare() {
- default
-
- eautoreconf
-
- # We need to copy the sources or else tests will fail
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
-}
-
-multilib_src_compile() {
- multilib_is_native_abi && default || emake libnuma.la
-}
-
-multilib_src_test() {
- if multilib_is_native_abi ; then
- if [[ -d /sys/devices/system/node ]] ; then
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- emake regress2
- else
- ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
- fi
- fi
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" \
- install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
- find "${ED}"/usr/ -type f -name libnuma.la -delete || die
-}
-
-multilib_src_install_all() {
- local DOCS=( README.md )
- einstalldocs
-
- # Delete man pages provided by the man-pages package, bug #238805
- rm -r "${ED}"/usr/share/man/man[25] || die
-}
diff --git a/sys-process/numactl/numactl-2.0.14.ebuild b/sys-process/numactl/numactl-2.0.14.ebuild
deleted file mode 100644
index 2e630ed1fb32..000000000000
--- a/sys-process/numactl/numactl-2.0.14.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic multilib-minimal
-
-DESCRIPTION="Utilities and libraries for NUMA systems"
-HOMEPAGE="https://github.com/numactl/numactl"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/numactl/numactl.git"
-else
- SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
- # ARM lacks the __NR_migrate_pages syscall.
- KEYWORDS="~alpha amd64 -arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.14-latomic.patch
- "${FILESDIR}"/${PN}-2.0.14-numademo-cflags.patch #540856
-)
-
-src_prepare() {
- default
-
- # lto not supported yet
- # gcc-9 with -flto leads to link failures: #692254
- filter-lto
-
- eautoreconf
- # We need to copy the sources or else tests will fail
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
-}
-
-multilib_src_compile() {
- multilib_is_native_abi && default || emake libnuma.la
-}
-
-multilib_src_test() {
- if multilib_is_native_abi ; then
- if [[ -d /sys/devices/system/node ]] ; then
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- emake regress2
- else
- ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
- fi
- fi
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" \
- install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
- find "${ED}"/usr/ -type f -name libnuma.la -delete || die
-}
-
-multilib_src_install_all() {
- local DOCS=( README.md )
- einstalldocs
- # delete man pages provided by the man-pages package #238805
- rm -r "${ED}"/usr/share/man/man[25] || die
-}
diff --git a/sys-process/numactl/numactl-2.0.16.ebuild b/sys-process/numactl/numactl-2.0.16.ebuild
deleted file mode 100644
index 110678fffc0c..000000000000
--- a/sys-process/numactl/numactl-2.0.16.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="Utilities and libraries for NUMA systems"
-HOMEPAGE="https://github.com/numactl/numactl"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/numactl/numactl.git"
-else
- SRC_URI="https://github.com/numactl/numactl/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.14-numademo-cflags.patch # bug #540856
-)
-
-src_prepare() {
- default
-
- eautoreconf
-
- # We need to copy the sources or else tests will fail
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
-}
-
-multilib_src_compile() {
- multilib_is_native_abi && default || emake libnuma.la
-}
-
-multilib_src_test() {
- if multilib_is_native_abi ; then
- if [[ -d /sys/devices/system/node ]] ; then
- einfo "The only generically safe test is regress2."
- einfo "The other test cases require 2 NUMA nodes."
- emake regress2
- else
- ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
- fi
- fi
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" \
- install$(multilib_is_native_abi || echo "-libLTLIBRARIES install-includeHEADERS")
- find "${ED}"/usr/ -type f -name libnuma.la -delete || die
-}
-
-multilib_src_install_all() {
- local DOCS=( README.md )
- einstalldocs
-
- # Delete man pages provided by the man-pages package, bug #238805
- rm -r "${ED}"/usr/share/man/man[25] || die
-}