summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-08-07 13:36:01 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-08-08 15:18:11 +0300
commitd77c4f6117e0966822e9113fe894e77759615d25 (patch)
treeb6675b57b894fbb65c2dd976c7d2d54602b2c311 /sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4-r1.ebuild
parentdev-util/sysdig-kmod: migrate to sys-apps/kmod (diff)
downloadgentoo-d77c4f6117e0966822e9113fe894e77759615d25.tar.gz
gentoo-d77c4f6117e0966822e9113fe894e77759615d25.tar.bz2
gentoo-d77c4f6117e0966822e9113fe894e77759615d25.zip
sys-power/tuxedo-cc-wmi: migrate to sys-apps/kmod
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4-r1.ebuild')
-rw-r--r--sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4-r1.ebuild b/sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..3810dcdaae36
--- /dev/null
+++ b/sys-power/tuxedo-cc-wmi/tuxedo-cc-wmi-0.1.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="Kernel Module for Tuxedo WMI"
+HOMEPAGE="https://github.com/tuxedocomputers/tuxedo-cc-wmi"
+SRC_URI="https://github.com/tuxedocomputers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BUILD_TARGETS="all"
+MODULE_NAMES="tuxedo_cc_wmi(tuxedo:${S}:src)"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KDIR=${KV_DIR} V=1 KBUILD_VERBOSE=1"
+}