summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-08-06 11:10:57 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-08-06 11:10:57 +0200
commit5d62f7c88b7cee84d1c7a399b6b7e9089e3eb558 (patch)
tree9bfb150bd3327250ae917fe04597ed44e77aed52 /sys-libs
parentx11-libs/gtkhotkey: eapi bump to 6 (diff)
downloadgentoo-5d62f7c88b7cee84d1c7a399b6b7e9089e3eb558.tar.gz
gentoo-5d62f7c88b7cee84d1c7a399b6b7e9089e3eb558.tar.bz2
gentoo-5d62f7c88b7cee84d1c7a399b6b7e9089e3eb558.zip
sys-libs/glibc: Forward-port some minor changes from 2.25 to 9999
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 3ac3d78a81be..026e3879bf50 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -100,7 +100,7 @@ upstream_uris() {
echo mirror://gnu/glibc/$1 ftp://sourceware.org/pub/glibc/{releases,snapshots}/$1 mirror://gentoo/$1
}
gentoo_uris() {
- local devspace="HTTP~vapier/dist/URI HTTP~azarah/glibc/URI"
+ local devspace="HTTP~vapier/dist/URI HTTP~tamiko/distfiles/URI HTTP~dilfridge/distfiles/URI"
devspace=${devspace//HTTP/https://dev.gentoo.org/}
echo mirror://gentoo/$1 ${devspace//URI/$1}
}
@@ -127,7 +127,7 @@ src_prepare() {
# includes backtraces and symbols.
einfo "Installing Hardened Gentoo SSP and FORTIFY_SOURCE handler"
cp "${FILESDIR}"/2.20/glibc-2.20-gentoo-stack_chk_fail.c debug/stack_chk_fail.c || die
- cp "${FILESDIR}"/2.20/glibc-2.20-gentoo-chk_fail.c debug/chk_fail.c || die
+ cp "${FILESDIR}"/2.25/glibc-2.25-gentoo-chk_fail.c debug/chk_fail.c || die
if use debug ; then
# Allow SIGABRT to dump core on non-hardened systems, or when debug is requested.
@@ -137,4 +137,12 @@ src_prepare() {
debug/Makefile || die
fi
fi
+
+ case $(gcc-fullversion) in
+ 4.8.[0-3]|4.9.0)
+ eerror "You need to switch to a newer compiler; gcc-4.8.[0-3] and gcc-4.9.0 miscompile"
+ eerror "glibc. See https://bugs.gentoo.org/547420 for details."
+ die "need to switch compilers #547420"
+ ;;
+ esac
}