summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2016-09-23 22:41:34 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-09-24 09:51:08 -0400
commitb37736d745e1ea1bf0e0bc10917dc6f84b21dbe0 (patch)
tree49a06684bff2ce4aa10d9791e3fd7a128cfc19d1 /sys-libs/musl/musl-9999.ebuild
parentdev-libs/confuse: amd64 stable wrt bug #593804 (diff)
downloadgentoo-b37736d745e1ea1bf0e0bc10917dc6f84b21dbe0.tar.gz
gentoo-b37736d745e1ea1bf0e0bc10917dc6f84b21dbe0.tar.bz2
gentoo-b37736d745e1ea1bf0e0bc10917dc6f84b21dbe0.zip
sys-libs/musl: revbump to improve the ldconfig script
Also add some more "|| die". Gentoo-Bug: https://bugs.gentoo.org/592268 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-libs/musl/musl-9999.ebuild')
-rw-r--r--sys-libs/musl/musl-9999.ebuild33
1 files changed, 6 insertions, 27 deletions
diff --git a/sys-libs/musl/musl-9999.ebuild b/sys-libs/musl/musl-9999.ebuild
index 906de18fb415..ae821369ecc3 100644
--- a/sys-libs/musl/musl-9999.ebuild
+++ b/sys-libs/musl/musl-9999.ebuild
@@ -46,17 +46,6 @@ just_headers() {
use crosscompile_opts_headers-only && is_crosscompile
}
-musl_endian() {
- # XXX: this wont work for bi-endian, but we dont have any
- touch "${T}"/endian.s || die
- $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
- case $(file "${T}"/endian.o) in
- *" MSB "*) echo "";;
- *" LSB "*) echo "el";;
- *) echo "nfc";; # We shouldn't be here
- esac
-}
-
pkg_setup() {
if [ ${CTARGET} == ${CHOST} ] ; then
case ${CHOST} in
@@ -76,7 +65,7 @@ src_configure() {
--target=${CTARGET} \
--prefix=${sysroot}/usr \
--syslibdir=${sysroot}/lib \
- --disable-gcc-wrapper
+ --disable-gcc-wrapper || die
}
src_compile() {
@@ -84,9 +73,9 @@ src_compile() {
just_headers && return 0
emake
- $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getconf.c -o "${T}"/getconf
- $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getent.c -o "${T}"/getent
- $(tc-getCC) ${CFLAGS} "${DISTDIR}"/iconv.c -o "${T}"/iconv
+ $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getconf.c -o "${T}"/getconf || die
+ $(tc-getCC) ${CFLAGS} "${DISTDIR}"/getent.c -o "${T}"/getent || die
+ $(tc-getCC) ${CFLAGS} "${DISTDIR}"/iconv.c -o "${T}"/iconv || die
}
src_install() {
@@ -102,17 +91,7 @@ src_install() {
dosym ${sysroot}/lib/${ldso} ${sysroot}/usr/bin/ldd
if [[ ${CATEGORY} != cross-* ]] ; then
- # TODO: We may be able to simplify this code by obtianing the arch name with
- # /usr/lib/libc.so 2>&1 | sed -n 's/^.*(\(.*\))$/\1/;1p'
- local target=$(tc-arch) arch
- local endian=$(musl_endian)
- case ${target} in
- amd64) arch="x86_64";;
- arm) arch="armhf";; # We only have hardfloat right now
- mips) arch="mips${endian}";;
- ppc) arch="powerpc";;
- x86) arch="i386";;
- esac
+ local arch=$("${D}"usr/lib/libc.so 2>&1 | sed -n '1s/^musl libc (\(.*\))$/\1/p')
cp "${FILESDIR}"/ldconfig.in "${T}" || die
sed -e "s|@@ARCH@@|${arch}|" "${T}"/ldconfig.in > "${T}"/ldconfig || die
into /
@@ -131,7 +110,7 @@ pkg_postinst() {
[ "${ROOT}" != "/" ] && return 0
- ldconfig
+ ldconfig || die
# reload init ...
/sbin/telinit U 2>/dev/null
}