summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLei Zhang <zhanglei.april@gmail.com>2016-09-18 18:27:12 +0800
committerMichał Górny <mgorny@gentoo.org>2016-09-29 15:24:29 +0200
commitd7f58d48e5faeeaca1b35efd557ae9171f770388 (patch)
treee28d76819b664072f12af6809e1f80d66ce287e2 /sys-libs/libomp/libomp-3.9.0.ebuild
parentmedia-libs/openjpeg: arm stable wrt bug #594740 (diff)
downloadgentoo-d7f58d48e5faeeaca1b35efd557ae9171f770388.tar.gz
gentoo-d7f58d48e5faeeaca1b35efd557ae9171f770388.tar.bz2
gentoo-d7f58d48e5faeeaca1b35efd557ae9171f770388.zip
sys-libs/libomp: bump to 3.9.0
Closes: https://github.com/gentoo/gentoo/pull/2426 Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-libs/libomp/libomp-3.9.0.ebuild')
-rw-r--r--sys-libs/libomp/libomp-3.9.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-libs/libomp/libomp-3.9.0.ebuild b/sys-libs/libomp/libomp-3.9.0.ebuild
new file mode 100644
index 000000000000..856ea692af71
--- /dev/null
+++ b/sys-libs/libomp/libomp-3.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-multilib
+
+MY_P=openmp-${PV}
+DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
+HOMEPAGE="http://openmp.llvm.org"
+SRC_URI="http://llvm.org/releases/${PV}/${MY_P}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0/3.9"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}.src"
+
+PATCHES=(
+ # backport of https://reviews.llvm.org/D24563
+ "${FILESDIR}"/${PN}-3.9.0-optional-aliases.patch
+)
+
+multilib_src_configure() {
+ local libdir="$(get_libdir)"
+ local mycmakeargs=(
+ -DLIBOMP_LIBDIR_SUFFIX="${libdir#lib}"
+ # do not install libgomp.so & libiomp5.so aliases
+ -DLIBOMP_INSTALL_ALIASES=OFF
+ # disable unnecessary hack copying stuff back to srcdir
+ -DLIBOMP_COPY_EXPORTS=OFF
+ )
+ cmake-utils_src_configure
+}