summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-16 23:09:32 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-17 19:11:04 +0200
commitd6535cc0b605b03af4e35cff1bf8ba9f0691dfaf (patch)
tree6123b4722547be8edfbb6d0c5f0f21d65d7644dd /sys-libs/glibc/glibc-9999.ebuild
parentdev-perl/Net-XMPP: EAPI=8 bump (diff)
downloadgentoo-d6535cc0b605b03af4e35cff1bf8ba9f0691dfaf.tar.gz
gentoo-d6535cc0b605b03af4e35cff1bf8ba9f0691dfaf.tar.bz2
gentoo-d6535cc0b605b03af4e35cff1bf8ba9f0691dfaf.zip
sys-libs/glibc: add preserve-libs for libcrypt
Bug: https://bugs.gentoo.org/802207 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index e2bc0dad8669..b3fc7c71c7b2 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9,10} )
TMPFILES_OPTIONAL=1
-inherit python-any-r1 prefix toolchain-funcs flag-o-matic gnuconfig \
+inherit python-any-r1 prefix preserve-libs toolchain-funcs flag-o-matic gnuconfig \
multilib systemd multiprocessing tmpfiles
DESCRIPTION="GNU libc C library"
@@ -1489,6 +1489,16 @@ pkg_preinst() {
# https://bugs.gentoo.org/753740
rm "${EROOT}"/usr/lib/locale || die
fi
+
+ # Keep around libcrypt so that Perl doesn't break when merging libxcrypt
+ # (libxcrypt is the new provider for now of libcrypt.so.{1,2}).
+ # bug #802207
+ if has_version "${CATEGORY}/${PN}[crypt]"; then
+ PRESERVED_OLD_LIBCRYPT=1
+ preserve_old_lib /$(get_libdir)/libcrypt$(get_libname 1)
+ else
+ PRESERVED_OLD_LIBCRYPT=0
+ fi
}
pkg_postinst() {
@@ -1518,4 +1528,8 @@ pkg_postinst() {
fi
done
fi
+
+ if [[ ${PRESERVED_OLD_LIBCRYPT} -eq 1 ]] ; then
+ preserve_old_lib_notify /$(get_libdir)/libcrypt$(get_libname 1)
+ fi
}