summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-07 07:54:10 +0100
committerSam James <sam@gentoo.org>2022-05-15 01:00:10 +0000
commit01ad1fecda61778081c5c1eaa051d7f6f2f4456c (patch)
tree86e061d8206d8b49e93819defb7d1c1f5d4a3c5c /sys-libs/glibc/glibc-2.31-r7.ebuild
parentsys-libs/pam: egrep -> grep -E (diff)
downloadgentoo-01ad1fecda61778081c5c1eaa051d7f6f2f4456c.tar.gz
gentoo-01ad1fecda61778081c5c1eaa051d7f6f2f4456c.tar.bz2
gentoo-01ad1fecda61778081c5c1eaa051d7f6f2f4456c.zip
sys-libs/glibc: egrep -> grep -E
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-2.31-r7.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.31-r7.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.31-r7.ebuild b/sys-libs/glibc/glibc-2.31-r7.ebuild
index 975a2dec59c9..61ff26514e5e 100644
--- a/sys-libs/glibc/glibc-2.31-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -633,7 +633,7 @@ sanity_prechecks() {
if [[ -e ${EROOT}/etc/nsswitch.conf ]] ; then
local entry
for entry in passwd group shadow; do
- if ! egrep -q "^[ \t]*${entry}:.*files" "${EROOT}"/etc/nsswitch.conf; then
+ if ! grep -E -q "^[ \t]*${entry}:.*files" "${EROOT}"/etc/nsswitch.conf; then
eerror "Your ${EROOT}/etc/nsswitch.conf is out of date."
eerror "Please make sure you have 'files' entries for"
eerror "'passwd:', 'group:' and 'shadow:' databases."
@@ -1486,7 +1486,7 @@ pkg_postinst() {
if [[ -e ${EROOT}/etc/nsswitch.conf ]] && ! has_version sys-auth/libnss-nis ; then
local entry
for entry in passwd group shadow; do
- if egrep -q "^[ \t]*${entry}:.*nis" "${EROOT}"/etc/nsswitch.conf; then
+ if grep -E -q "^[ \t]*${entry}:.*nis" "${EROOT}"/etc/nsswitch.conf; then
ewarn ""
ewarn "Your ${EROOT}/etc/nsswitch.conf uses NIS. Support for that has been"
ewarn "removed from glibc and is now provided by the package"