summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-19 21:53:45 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-19 21:53:45 +0100
commit39a93261bdd1802de0483c03802b3bdf1e0415e7 (patch)
tree11759b073f87ae972b98ddfa88aef5ecc11b6a44 /sys-fs
parentdev-ml/ocamlfuse: add 2.7.1_p11 (diff)
downloadgentoo-39a93261bdd1802de0483c03802b3bdf1e0415e7.tar.gz
gentoo-39a93261bdd1802de0483c03802b3bdf1e0415e7.tar.bz2
gentoo-39a93261bdd1802de0483c03802b3bdf1e0415e7.zip
sys-fs/google-drive-ocamlfuse: add 0.7.32
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/google-drive-ocamlfuse/Manifest1
-rw-r--r--sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.32.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/google-drive-ocamlfuse/Manifest b/sys-fs/google-drive-ocamlfuse/Manifest
index 48c9b62d13d7..a656ab238b44 100644
--- a/sys-fs/google-drive-ocamlfuse/Manifest
+++ b/sys-fs/google-drive-ocamlfuse/Manifest
@@ -1,2 +1,3 @@
DIST google-drive-ocamlfuse-0.7.29.gh.tar.gz 98832 BLAKE2B 7a959047abacc65379c2da0f590c6dba613cb7708dd56a7e029409d8791d76e6a0a164eea113b21a84b07bf522879401833431482f18d97865364eaee03dcb3b SHA512 562bca2e9019a999886052eb4b7f6554706c25be69670148c1938d3b30d742b03eafb6fba430c4762ba44713e291ec3b0cddabc1baaa6491740ddd3e77655fe9
DIST google-drive-ocamlfuse-0.7.30.gh.tar.gz 98849 BLAKE2B 89ff486cc13d86b67ef4ceda769ff7e144d91cf8c4ce67a8d8fb011f7a26a2c21e802c71dbb8bda50b871de089cd6c70762bcb9640c841c84dcd8696b011ebee SHA512 4182ab3697b84afa983ea033f6de7f94a3482f2c9c9024c875feeee0ed196dbe33c97fa88a0a86c818b55f30eddd1f3d9ab674dd4a6df2a1f8abcfc793f4d4b3
+DIST google-drive-ocamlfuse-0.7.32.gh.tar.gz 100268 BLAKE2B 21d1fed8e605afdf5dcce41ee26b786031cf9a958d1b0794d172d9bfacd7efc290a7411bd5c5505faae8d61a19438ac06bd8ddf7044babbac0b50dc690499d6e SHA512 b33bd010fafb28659c0a7f33a04d02a2402dbac23688efebce15fc86c0fb038f771a94da4d828bb72041bdbae9a10b60fce6db6dc32fa895a82f5cfca4ff2845
diff --git a/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.32.ebuild b/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.32.ebuild
new file mode 100644
index 000000000000..efdc7bcfe84b
--- /dev/null
+++ b/sys-fs/google-drive-ocamlfuse/google-drive-ocamlfuse-0.7.32.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune findlib
+
+DESCRIPTION="FUSE filesystem over Google Drive"
+HOMEPAGE="
+ https://github.com/astrada/google-drive-ocamlfuse
+ https://opam.ocaml.org/packages/google-drive-ocamlfuse/
+"
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ >=dev-ml/gapi-ocaml-0.4.2:=
+ >=dev-ml/ocamlfuse-2.7.1:=
+ dev-ml/cryptokit:=
+ dev-ml/extlib:=
+ dev-ml/ocaml-sqlite3:=
+ >=dev-ml/tiny_httpd-0.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/camlidl:=
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"