summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 04:19:08 +0000
committerSam James <sam@gentoo.org>2023-12-28 04:19:08 +0000
commit041dddb049c18be7035e9ad85ecf0e500175cd6d (patch)
treef2b1eab53fd023c1ea19deb82c6c721b27ad7f91 /sys-fs/fuse/fuse-3.15.1.ebuild
parentsys-process/cronie: drop 1.6.1-r3 (diff)
downloadgentoo-041dddb049c18be7035e9ad85ecf0e500175cd6d.tar.gz
gentoo-041dddb049c18be7035e9ad85ecf0e500175cd6d.tar.bz2
gentoo-041dddb049c18be7035e9ad85ecf0e500175cd6d.zip
sys-fs/fuse: drop 3.15.0, 3.15.1, 3.16.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/fuse/fuse-3.15.1.ebuild')
-rw-r--r--sys-fs/fuse/fuse-3.15.1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/sys-fs/fuse/fuse-3.15.1.ebuild b/sys-fs/fuse/fuse-3.15.1.ebuild
deleted file mode 100644
index 10840ae807b0..000000000000
--- a/sys-fs/fuse/fuse-3.15.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-inherit flag-o-matic meson-multilib udev python-any-r1
-
-DESCRIPTION="An interface for filesystems implemented in userspace"
-HOMEPAGE="https://github.com/libfuse/libfuse"
-SRC_URI="https://github.com/libfuse/libfuse/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="3"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+suid test"
-RESTRICT="!test? ( test ) test? ( userpriv )"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )
-"
-RDEPEND=">=sys-fs/fuse-common-3.3.0-r1"
-
-DOCS=( AUTHORS ChangeLog.rst README.md doc/README.NFS doc/kernel.txt )
-
-python_check_deps() {
- python_has_version "dev-python/pytest[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-multilib_src_configure() {
- # bug #853058
- filter-lto
-
- local emesonargs=(
- $(meson_use test examples)
- $(meson_use test tests)
- -Duseroot=false
- -Dinitscriptdir=
- -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
- )
- meson_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "Sandbox enabled, skipping tests"
- else
- multilib-minimal_src_test
- fi
-}
-
-multilib_src_test() {
- epytest
-}
-
-multilib_src_install_all() {
- # Installed via fuse-common
- rm -r "${ED}"{/etc,$(get_udevdir)} || die
-
- # useroot=false prevents the build system from doing this.
- use suid && fperms u+s /usr/bin/fusermount3
-
- # manually install man pages to respect compression
- rm -r "${ED}"/usr/share/man || die
- doman doc/{fusermount3.1,mount.fuse3.8}
-}