summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-19 08:40:58 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-19 08:47:39 +0100
commit80f6a7131e495d4125a448f8c946c92774074f6f (patch)
treee6f49c0ff4881012acdfa271ff4a98aa982b5871 /sys-fs/duperemove
parentdev-python/jupyterlab: Bump to 4.0.9 (diff)
downloadgentoo-80f6a7131e495d4125a448f8c946c92774074f6f.tar.gz
gentoo-80f6a7131e495d4125a448f8c946c92774074f6f.tar.bz2
gentoo-80f6a7131e495d4125a448f8c946c92774074f6f.zip
sys-fs/duperemove: Bump to 0.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/duperemove')
-rw-r--r--sys-fs/duperemove/Manifest1
-rw-r--r--sys-fs/duperemove/duperemove-0.14.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/duperemove/Manifest b/sys-fs/duperemove/Manifest
index 1e29cc7dda9e..5601fe4b57c2 100644
--- a/sys-fs/duperemove/Manifest
+++ b/sys-fs/duperemove/Manifest
@@ -1,2 +1,3 @@
DIST duperemove-0.12.gh.tar.gz 162458 BLAKE2B 53dae9df2b45cb9ede8041e8a7a827c22c725da51d6df74acc96b464d4bfcc3a14b8adcd4b9ada68e2cf1411a5f015be27476e088a655998b0cc9d1f19acfae8 SHA512 7b5f464615f4ba850733657239dd4d68120d592424b6be56687b7ad4f6fd2dee67fd7729a1cd47c803dd77864dee033d8eef2f7f6774dc0f657b0d52aeb5559c
DIST duperemove-0.13.gh.tar.gz 165454 BLAKE2B 8bfac3448b5ee8842be77b0ac969439197050d3ef4b245be85a918353c966e56d7b7505e004af830caca50732d1227795769d803640f422a1bed8ca299802e75 SHA512 e24fa9f658acf1c1badd797af719f81250861b9af4595cf96aa3583fe558a2fba7390bc06184f6a4b6c76be3c8b214d6a6ead8b0de6914a5e1df053d5e7e24e7
+DIST duperemove-0.14.gh.tar.gz 167844 BLAKE2B 3f489ca29e3417cacb186fe5d93de2d1a1052a1fc04811c8853e30430e883daaa8cce9262efbe3d6535295cc53904c2c996fda397b24601a045907c9035f6601 SHA512 3a205d2cbf92a3d9a0f48d276a153b2259514cbb2a5911d63830cc145711118642329f164464ebd6639b764a624c8f9e59b19779a36155f5709f45e59689c008
diff --git a/sys-fs/duperemove/duperemove-0.14.ebuild b/sys-fs/duperemove/duperemove-0.14.ebuild
new file mode 100644
index 000000000000..174acf956523
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs and xfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove/"
+SRC_URI="
+ https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz
+ -> ${P/_/.}.gh.tar.gz
+"
+S=${WORKDIR}/${P/_/.}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_compile() {
+ emake VERSION="${PV}" IS_RELEASE=1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}