summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2024-10-18 00:52:01 +0100
committerSam James <sam@gentoo.org>2024-10-18 02:31:22 +0100
commit96a3b69fe604926908eab27204f9e96bb705c7b2 (patch)
tree08a57ac0570ae31713b260e243b930d681e4f8f9 /sys-devel
parentprofiles/prefix/darwin/macos: add x64/clang profiles (diff)
downloadgentoo-96a3b69fe604926908eab27204f9e96bb705c7b2.tar.gz
gentoo-96a3b69fe604926908eab27204f9e96bb705c7b2.tar.bz2
gentoo-96a3b69fe604926908eab27204f9e96bb705c7b2.zip
sys-devel/clang-common: pass flags on darwin differently
Bug: https://bugs.gentoo.org/758167 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-19.1.1.ebuild14
-rw-r--r--sys-devel/clang-common/clang-common-19.1.2.ebuild14
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0.9999.ebuild14
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20241009.ebuild14
-rw-r--r--sys-devel/clang-common/clang-common-20.0.0_pre20241015.ebuild14
5 files changed, 50 insertions, 20 deletions
diff --git a/sys-devel/clang-common/clang-common-19.1.1.ebuild b/sys-devel/clang-common/clang-common-19.1.1.ebuild
index 96be6fb619b1..d587000e70f7 100644
--- a/sys-devel/clang-common/clang-common-19.1.1.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.1.ebuild
@@ -274,10 +274,6 @@ src_install() {
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
# Gentoo Prefix on Darwin
-Wl,-search_paths_first
- -Wl,-rpath,${EPREFIX}/usr/lib
- -L ${EPREFIX}/usr/lib
- -isystem ${EPREFIX}/usr/include
- -isysroot ${EPREFIX}/MacOSX.sdk
EOF
if use bootstrap-prefix ; then
# bootstrap-prefix is only set during stage2 of bootstrapping
@@ -286,8 +282,18 @@ src_install() {
# EPREFIX.
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
-Wl,-rpath,${EPREFIX}/../usr/lib
+ -Wl,-L,${EPREFIX}/../usr/lib
+ -isystem ${EPREFIX}/../usr/include
EOF
fi
+ # Using -Wl,-L instead of -L to trick compiler driver to put it
+ # after -isysroot's internal -L
+ cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
+ -Wl,-rpath,${EPREFIX}/usr/lib
+ -Wl,-L,${EPREFIX}/usr/lib
+ -isystem ${EPREFIX}/usr/include
+ -isysroot ${EPREFIX}/MacOSX.sdk
+ EOF
fi
}
diff --git a/sys-devel/clang-common/clang-common-19.1.2.ebuild b/sys-devel/clang-common/clang-common-19.1.2.ebuild
index 96be6fb619b1..d587000e70f7 100644
--- a/sys-devel/clang-common/clang-common-19.1.2.ebuild
+++ b/sys-devel/clang-common/clang-common-19.1.2.ebuild
@@ -274,10 +274,6 @@ src_install() {
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
# Gentoo Prefix on Darwin
-Wl,-search_paths_first
- -Wl,-rpath,${EPREFIX}/usr/lib
- -L ${EPREFIX}/usr/lib
- -isystem ${EPREFIX}/usr/include
- -isysroot ${EPREFIX}/MacOSX.sdk
EOF
if use bootstrap-prefix ; then
# bootstrap-prefix is only set during stage2 of bootstrapping
@@ -286,8 +282,18 @@ src_install() {
# EPREFIX.
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
-Wl,-rpath,${EPREFIX}/../usr/lib
+ -Wl,-L,${EPREFIX}/../usr/lib
+ -isystem ${EPREFIX}/../usr/include
EOF
fi
+ # Using -Wl,-L instead of -L to trick compiler driver to put it
+ # after -isysroot's internal -L
+ cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
+ -Wl,-rpath,${EPREFIX}/usr/lib
+ -Wl,-L,${EPREFIX}/usr/lib
+ -isystem ${EPREFIX}/usr/include
+ -isysroot ${EPREFIX}/MacOSX.sdk
+ EOF
fi
}
diff --git a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
index 6eb8b79a8c99..0351c7b25564 100644
--- a/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0.9999.ebuild
@@ -274,10 +274,6 @@ src_install() {
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
# Gentoo Prefix on Darwin
-Wl,-search_paths_first
- -Wl,-rpath,${EPREFIX}/usr/lib
- -L ${EPREFIX}/usr/lib
- -isystem ${EPREFIX}/usr/include
- -isysroot ${EPREFIX}/MacOSX.sdk
EOF
if use bootstrap-prefix ; then
# bootstrap-prefix is only set during stage2 of bootstrapping
@@ -286,8 +282,18 @@ src_install() {
# EPREFIX.
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
-Wl,-rpath,${EPREFIX}/../usr/lib
+ -Wl,-L,${EPREFIX}/../usr/lib
+ -isystem ${EPREFIX}/../usr/include
EOF
fi
+ # Using -Wl,-L instead of -L to trick compiler driver to put it
+ # after -isysroot's internal -L
+ cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
+ -Wl,-rpath,${EPREFIX}/usr/lib
+ -Wl,-L,${EPREFIX}/usr/lib
+ -isystem ${EPREFIX}/usr/include
+ -isysroot ${EPREFIX}/MacOSX.sdk
+ EOF
fi
}
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20241009.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20241009.ebuild
index 6eb8b79a8c99..0351c7b25564 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20241009.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20241009.ebuild
@@ -274,10 +274,6 @@ src_install() {
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
# Gentoo Prefix on Darwin
-Wl,-search_paths_first
- -Wl,-rpath,${EPREFIX}/usr/lib
- -L ${EPREFIX}/usr/lib
- -isystem ${EPREFIX}/usr/include
- -isysroot ${EPREFIX}/MacOSX.sdk
EOF
if use bootstrap-prefix ; then
# bootstrap-prefix is only set during stage2 of bootstrapping
@@ -286,8 +282,18 @@ src_install() {
# EPREFIX.
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
-Wl,-rpath,${EPREFIX}/../usr/lib
+ -Wl,-L,${EPREFIX}/../usr/lib
+ -isystem ${EPREFIX}/../usr/include
EOF
fi
+ # Using -Wl,-L instead of -L to trick compiler driver to put it
+ # after -isysroot's internal -L
+ cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
+ -Wl,-rpath,${EPREFIX}/usr/lib
+ -Wl,-L,${EPREFIX}/usr/lib
+ -isystem ${EPREFIX}/usr/include
+ -isysroot ${EPREFIX}/MacOSX.sdk
+ EOF
fi
}
diff --git a/sys-devel/clang-common/clang-common-20.0.0_pre20241015.ebuild b/sys-devel/clang-common/clang-common-20.0.0_pre20241015.ebuild
index 6eb8b79a8c99..0351c7b25564 100644
--- a/sys-devel/clang-common/clang-common-20.0.0_pre20241015.ebuild
+++ b/sys-devel/clang-common/clang-common-20.0.0_pre20241015.ebuild
@@ -274,10 +274,6 @@ src_install() {
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
# Gentoo Prefix on Darwin
-Wl,-search_paths_first
- -Wl,-rpath,${EPREFIX}/usr/lib
- -L ${EPREFIX}/usr/lib
- -isystem ${EPREFIX}/usr/include
- -isysroot ${EPREFIX}/MacOSX.sdk
EOF
if use bootstrap-prefix ; then
# bootstrap-prefix is only set during stage2 of bootstrapping
@@ -286,8 +282,18 @@ src_install() {
# EPREFIX.
cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
-Wl,-rpath,${EPREFIX}/../usr/lib
+ -Wl,-L,${EPREFIX}/../usr/lib
+ -isystem ${EPREFIX}/../usr/include
EOF
fi
+ # Using -Wl,-L instead of -L to trick compiler driver to put it
+ # after -isysroot's internal -L
+ cat >> "${ED}/etc/clang/gentoo-common.cfg" <<-EOF || die
+ -Wl,-rpath,${EPREFIX}/usr/lib
+ -Wl,-L,${EPREFIX}/usr/lib
+ -isystem ${EPREFIX}/usr/include
+ -isysroot ${EPREFIX}/MacOSX.sdk
+ EOF
fi
}