summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-10 23:58:20 +0100
committerSam James <sam@gentoo.org>2023-04-10 23:58:20 +0100
commit041698b1bf9e93308ff879cb444866caf1ac53a7 (patch)
treef3ef0f78db0608fb969ac50300fed4dea6d3998b /sys-devel
parenttoolchain.eclass: use upstream default checking for pre/non-released compilers (diff)
downloadgentoo-041698b1bf9e93308ff879cb444866caf1ac53a7.tar.gz
gentoo-041698b1bf9e93308ff879cb444866caf1ac53a7.tar.bz2
gentoo-041698b1bf9e93308ff879cb444866caf1ac53a7.zip
sys-devel/gcc: revbump for toolchain.eclass checking change for 13
See 564b130fd1bc8a35ac4d673d5211654c49af3fda. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-13.0.1_pre20230409-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-13.0.1_pre20230409-r1.ebuild b/sys-devel/gcc/gcc-13.0.1_pre20230409-r1.ebuild
new file mode 100644
index 000000000000..f476227f8198
--- /dev/null
+++ b/sys-devel/gcc/gcc-13.0.1_pre20230409-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+TOOLCHAIN_PATCH_DEV="sam"
+PATCH_VER="9"
+PATCH_GCC_VER="13.1.0"
+MUSL_VER="1"
+MUSL_GCC_VER="13.1.0"
+
+if [[ $(ver_cut 3) == 9999 ]] ; then
+ MY_PV_2=$(ver_cut 2)
+ MY_PV_3=$(($(ver_cut 3) - 9998))
+ if [[ ${MY_PV_2} == 0 ]] ; then
+ MY_PV_2=0
+ MY_PV_3=0
+ else
+ MY_PV_2=$(($(ver_cut 2) - 1))
+ fi
+
+ # e.g. 12.2.9999 -> 12.1.1
+ TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.${MY_PV_3}
+fi
+
+inherit toolchain
+# Needs to be after inherit (for now?), bug #830908
+EGIT_BRANCH=master
+
+# Don't keyword live ebuilds
+if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
+# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~loong"
+fi
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ # Technically only if USE=hardened *too* right now, but no point in complicating it further.
+ # If GCC is enabling CET by default, we need glibc to be built with support for it.
+ # bug #830454
+ RDEPEND="elibc_glibc? ( sys-libs/glibc[cet(-)?] )"
+ DEPEND="${RDEPEND}"
+ BDEPEND=">=${CATEGORY}/binutils-2.30[cet(-)?]"
+fi
+
+src_prepare() {
+ local p upstreamed_patches=(
+ # add them here
+ )
+ for p in "${upstreamed_patches[@]}"; do
+ rm -v "${WORKDIR}/patch/${p}" || die
+ done
+
+ toolchain_src_prepare
+
+ eapply_user
+}