summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 13:13:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 13:17:45 +0200
commit7d2ba3742b95819ff57590238544a7574c66596b (patch)
tree4c8840ba1f0c271479e579e4c6422fdb0fc7e4a0 /sys-devel/llvm-toolchain-symlinks
parentwww-client/firefox: add 102.3.0 (diff)
downloadgentoo-7d2ba3742b95819ff57590238544a7574c66596b.tar.gz
gentoo-7d2ba3742b95819ff57590238544a7574c66596b.tar.bz2
gentoo-7d2ba3742b95819ff57590238544a7574c66596b.zip
sys-devel/llvm-toolchain-symlinks: Add for LLVM 15.x
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/llvm-toolchain-symlinks')
-rw-r--r--sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-15.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-15.ebuild b/sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-15.ebuild
new file mode 100644
index 000000000000..9cc42ef77e31
--- /dev/null
+++ b/sys-devel/llvm-toolchain-symlinks/llvm-toolchain-symlinks-15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Symlinks to use LLVM on binutils-free system"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+native-symlinks"
+
+RDEPEND="
+ sys-devel/llvm:${SLOT}
+"
+
+src_install() {
+ use native-symlinks || return
+
+ local tools=(
+ addr2line ar dlltool nm objcopy objdump ranlib readelf size
+ strings strip windres
+ )
+
+ local abi t
+ local dest=/usr/lib/llvm/${SLOT}/bin
+ dodir "${dest}"
+ for t in "${tools[@]}"; do
+ dosym "llvm-${t}" "${dest}/${t}"
+ done
+ for abi in $(get_all_abis); do
+ local abi_chost=$(get_abi_CHOST "${abi}")
+ for t in "${tools[@]}"; do
+ dosym "llvm-${t}" "${dest}/${abi_chost}-${t}"
+ done
+ done
+}