summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-06 16:38:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-06 17:03:50 +0100
commit3e5121dfda07c326cf59b2a0a7301255a5f2116e (patch)
tree564173d8c595d95ecd7b617e169d9c97178aa4e7 /sys-devel/clang-runtime
parentsys-libs/llvm-libunwind: Switch 14.x to runtimes build (diff)
downloadgentoo-3e5121dfda07c326cf59b2a0a7301255a5f2116e.tar.gz
gentoo-3e5121dfda07c326cf59b2a0a7301255a5f2116e.tar.bz2
gentoo-3e5121dfda07c326cf59b2a0a7301255a5f2116e.zip
sys-devel/clang-runtime: Add multilib-ish USE-deps on compiler-rt
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-devel/clang-runtime')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.0.9999.ebuild8
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.0_rc2.ebuild6
-rw-r--r--sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild6
3 files changed, 13 insertions, 7 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.0.9999.ebuild
index 218cdb1426f6..e02d928d2be4 100644
--- a/sys-devel/clang-runtime/clang-runtime-14.0.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,8 +18,10 @@ PROPERTIES="live"
RDEPEND="
compiler-rt? (
- ~sys-libs/compiler-rt-${PV}:${SLOT}
- sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.0_rc2.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.0_rc2.ebuild
index 23ad83f3671d..e02d928d2be4 100644
--- a/sys-devel/clang-runtime/clang-runtime-14.0.0_rc2.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.0_rc2.ebuild
@@ -18,8 +18,10 @@ PROPERTIES="live"
RDEPEND="
compiler-rt? (
- ~sys-libs/compiler-rt-${PV}:${SLOT}
- sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"
diff --git a/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
index 23ad83f3671d..e02d928d2be4 100644
--- a/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-15.0.0.9999.ebuild
@@ -18,8 +18,10 @@ PROPERTIES="live"
RDEPEND="
compiler-rt? (
- ~sys-libs/compiler-rt-${PV}:${SLOT}
- sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ ~sys-libs/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
)
libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"