summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-18 03:07:19 +0000
committerSam James <sam@gentoo.org>2024-01-18 03:19:20 +0000
commit54485713cf0ce8a8af217688b7ac5ef9099e3b88 (patch)
treecc476b8682f3b84b32b098c2c5b787846fe8ba8e /sys-devel/bison
parentapp-arch/cpio: run tests in parallel (diff)
downloadgentoo-54485713cf0ce8a8af217688b7ac5ef9099e3b88.tar.gz
gentoo-54485713cf0ce8a8af217688b7ac5ef9099e3b88.tar.bz2
gentoo-54485713cf0ce8a8af217688b7ac5ef9099e3b88.zip
sys-devel/bison: run tests in parallel
Inspired by vapier's cd7f047fe43fb631c4ca6979c6efb5038c616f41. `RUNTESTFLAGS` has been in the back of my head for a while now as I've been meaning to figure out the interaction between it and parallel make and which packages actually need it. This saves about 30s for me on a fast machine. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/bison-3.8.2-r2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/bison/bison-3.8.2-r2.ebuild b/sys-devel/bison/bison-3.8.2-r2.ebuild
index fd8742c3ad61..b778f945857a 100644
--- a/sys-devel/bison/bison-3.8.2-r2.ebuild
+++ b/sys-devel/bison/bison-3.8.2-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/bison.asc
-inherit flag-o-matic verify-sig
+inherit flag-o-matic multiprocessing verify-sig
DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
HOMEPAGE="https://www.gnu.org/software/bison/"
@@ -68,6 +68,10 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ emake check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+}
+
src_install() {
default