summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-11-11 09:46:44 +0100
committerJustin Lecher <jlec@gentoo.org>2016-11-11 09:46:56 +0100
commit1089e25a13c2c425ad3fbb9b0a72619b567462a9 (patch)
treedb16f6368493643a72a03a8624c7bd743689ba8c /sys-cluster/singularity/singularity-2.2.ebuild
parentsys-devel/clang: Enable RISCV target on -9999 (diff)
downloadgentoo-1089e25a13c2c425ad3fbb9b0a72619b567462a9.tar.gz
gentoo-1089e25a13c2c425ad3fbb9b0a72619b567462a9.tar.bz2
gentoo-1089e25a13c2c425ad3fbb9b0a72619b567462a9.zip
sys-cluster/singularity: New package, ebuild written by me
Package-Manager: portage-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity/singularity-2.2.ebuild')
-rw-r--r--sys-cluster/singularity/singularity-2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-cluster/singularity/singularity-2.2.ebuild b/sys-cluster/singularity/singularity-2.2.ebuild
new file mode 100644
index 000000000000..7fb0f7cbf178
--- /dev/null
+++ b/sys-cluster/singularity/singularity-2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="http://singularity.lbl.gov/"
+SRC_URI="https://github.com/${PN}ware/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_configure() {
+ econf --with-userns
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}