summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/ploop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/ploop')
-rw-r--r--sys-cluster/ploop/Manifest1
-rw-r--r--sys-cluster/ploop/files/ploop-1.2-soname.patch19
-rw-r--r--sys-cluster/ploop/files/ploop.tmpfiles1
-rw-r--r--sys-cluster/ploop/metadata.xml10
-rw-r--r--sys-cluster/ploop/ploop-1.13.2.ebuild59
5 files changed, 90 insertions, 0 deletions
diff --git a/sys-cluster/ploop/Manifest b/sys-cluster/ploop/Manifest
new file mode 100644
index 000000000000..056d0d085246
--- /dev/null
+++ b/sys-cluster/ploop/Manifest
@@ -0,0 +1 @@
+DIST ploop-1.13.2.tar.bz2 122821 SHA256 c1705c3bebd4f0f8860fecadf57cca457216b2abad880eb36098351244f9c1c3 SHA512 85a3314dc1114b692cd98290412fd2ea78c516964c712487dd72f8347fd583172d8836f997d63ccade89ee39be031669074d9bc957926b97175e659ec505ddfb WHIRLPOOL aea714ec18aa82cce2fcffa9aafdfe0e627ed83db9b8eaf0621b2dddb58fd300fdd9a3896e2e5192154cc5e0b6b11668128ed2e66fd04c1daae84e23d41c7a99
diff --git a/sys-cluster/ploop/files/ploop-1.2-soname.patch b/sys-cluster/ploop/files/ploop-1.2-soname.patch
new file mode 100644
index 000000000000..34cd56567c43
--- /dev/null
+++ b/sys-cluster/ploop/files/ploop-1.2-soname.patch
@@ -0,0 +1,19 @@
+--- lib/Makefile 2012-05-03 21:11:04.000000000 +0400
++++ lib/Makefile 2012-05-03 21:10:47.000000000 +0400
+@@ -2,6 +2,7 @@
+
+ LIBPLOOP=libploop.a
+ LIBPLOOP_DYN = libploop.so
++SONAME = $(LIBPLOOP_DYN).0
+ LIBOBJS=uuid.o \
+ delta_read.o \
+ delta_sysfs.o \
+@@ -36,7 +37,7 @@
+
+ $(LIBPLOOP_DYN): $(LIBOBJS)
+ $(E) " LINK " $@
+- $(Q) $(CC) $(CFLAGS) $(INC) $(LDFLAGS) -shared $^ ${LDLIBS} -o $@
++ $(Q) $(CC) $(CFLAGS) $(INC) $(LDFLAGS) -shared $^ ${LDLIBS} -o $@ -Wl,-soname,$(SONAME)
+
+ .depend: $(SOURCES)
+ -include .depend
diff --git a/sys-cluster/ploop/files/ploop.tmpfiles b/sys-cluster/ploop/files/ploop.tmpfiles
new file mode 100644
index 000000000000..25feee63db2a
--- /dev/null
+++ b/sys-cluster/ploop/files/ploop.tmpfiles
@@ -0,0 +1 @@
+d /run/lock/ploop 0755 root root - -
diff --git a/sys-cluster/ploop/metadata.xml b/sys-cluster/ploop/metadata.xml
new file mode 100644
index 000000000000..308c5433cf06
--- /dev/null
+++ b/sys-cluster/ploop/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>andreis.vinogradovs@gmail.com</email>
+ <name>Andreis Vinogradovs</name>
+ <description>Primary maintainer, assign bugs to him</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/ploop/ploop-1.13.2.ebuild b/sys-cluster/ploop/ploop-1.13.2.ebuild
new file mode 100644
index 000000000000..3e95c48fa3e1
--- /dev/null
+++ b/sys-cluster/ploop/ploop-1.13.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib systemd
+
+DESCRIPTION="openvz tool and a library to control ploop block devices"
+HOMEPAGE="http://wiki.openvz.org/Download/ploop"
+SRC_URI="http://download.openvz.org/utils/ploop/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug static-libs"
+
+DEPEND="
+ dev-libs/libxml2
+ virtual/pkgconfig
+ "
+
+RDEPEND="dev-libs/libxml2
+ !<sys-cluster/vzctl-4.8
+ sys-block/parted
+ sys-fs/e2fsprogs
+ sys-process/lsof
+ sys-apps/findutils
+ "
+
+DOCS=( tools/README )
+
+src_prepare() {
+ # Respect CFLAGS and CC, do not add debug by default
+ sed -i \
+ -e 's|CFLAGS =|CFLAGS +=|' \
+ -e '/CFLAGS/s/-g -O0 //' \
+ -e '/CFLAGS/s/-O2//' \
+ -e 's|CC=|CC?=|' \
+ -e 's/-Werror//' \
+ -e '/DEBUG=yes/d' \
+ -e '/LOCKDIR/s/var/run/' \
+ Makefile.inc || die 'sed on Makefile.inc failed'
+ # Avoid striping of binaries
+ sed -e '/INSTALL/{s: -s::}' -i tools/Makefile || die 'sed on tools/Makefile failed'
+
+ # respect AR and RANLIB, bug #452092
+ tc-export AR RANLIB
+ sed -i -e 's/ranlib/$(RANLIB)/' lib/Makefile || die 'sed on lib/Makefile failed'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" V=1 $(usex debug 'DEBUG' '' '=yes' '')
+}
+
+src_install() {
+ default
+ ldconfig -n "${D}/usr/$(get_libdir)/" || die
+}