summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/yubikey-personalization-gui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/yubikey-personalization-gui')
-rw-r--r--sys-auth/yubikey-personalization-gui/Manifest2
-rw-r--r--sys-auth/yubikey-personalization-gui/metadata.xml12
-rw-r--r--sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.18.ebuild41
-rw-r--r--sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.20.ebuild41
4 files changed, 96 insertions, 0 deletions
diff --git a/sys-auth/yubikey-personalization-gui/Manifest b/sys-auth/yubikey-personalization-gui/Manifest
new file mode 100644
index 000000000000..87ce76a22072
--- /dev/null
+++ b/sys-auth/yubikey-personalization-gui/Manifest
@@ -0,0 +1,2 @@
+DIST yubikey-personalization-gui-3.1.18.tar.gz 1450161 SHA256 83e375bff4844ebebf473dfa9f62526689cb5160f7a8dca56896c8f47e3cb1cb SHA512 039b27f6b475d63fb0bc5de8dfaa1f8b86652a483c2a2930d74fc7ae1105232146283071fe1e6b0225e85397fcae46a7724e7f0e5c8f20685c6b18d0dced95c8 WHIRLPOOL 83176c32fc6d252d675124a7b0a16e7be49bea758bae4dc512b2f7e14ad27bc59bdec521882863c0b77ccd6c19c36a5cce24fa9b07ffa7ad636d120fee9539b5
+DIST yubikey-personalization-gui-3.1.20.tar.gz 1458155 SHA256 70e31105900b571792de8ccd41ac4b080a10ecd8c7268c44b4676752d350f994 SHA512 d8b9165ade8f9a8be24d3aabd1b5096c01842e719bf7b70d46a54fd809d2fcbbf515ef95759f00601cf9fa6dcc01aa0e0de802da643c306eacdf7c1a1a576081 WHIRLPOOL 0c9589424a2fa51558d90bf7ee5410746683f57949836fd7c16f89f164c8eb4c60dc9386b5403f78187254d838e5eecaca8188b560a391e7da449e49e8377dfe
diff --git a/sys-auth/yubikey-personalization-gui/metadata.xml b/sys-auth/yubikey-personalization-gui/metadata.xml
new file mode 100644
index 000000000000..47ed1ce8d6ad
--- /dev/null
+++ b/sys-auth/yubikey-personalization-gui/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary mainainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubikey-personalization</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.18.ebuild b/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.18.ebuild
new file mode 100644
index 000000000000..7f886d6d73ed
--- /dev/null
+++ b/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qt4-r2
+
+DESCRIPTION="GUI for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization-gui/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization-gui"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="debug"
+
+RDEPEND="
+ >=sys-auth/ykpers-1.14.0
+ >=sys-auth/libyubikey-1.6
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ dev-libs/glib:2
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( NEWS README )
+
+src_configure() {
+ eqmake4 YKPersonalization.pro
+}
+
+src_install() {
+ dobin build/release/yubikey-personalization-gui
+ doman resources/lin/yubikey-personalization-gui.1
+ domenu resources/lin/yubikey-personalization-gui.desktop
+ doicon resources/lin/yubikey-personalization-gui.xpm
+ doicon -s 128 resources/lin/yubikey-personalization-gui.png
+}
diff --git a/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.20.ebuild b/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.20.ebuild
new file mode 100644
index 000000000000..eb899abb4023
--- /dev/null
+++ b/sys-auth/yubikey-personalization-gui/yubikey-personalization-gui-3.1.20.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils qmake-utils
+
+DESCRIPTION="GUI for personalization of Yubico's YubiKey"
+SRC_URI="http://yubico.github.io/yubikey-personalization-gui/releases/${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization-gui"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="debug"
+
+RDEPEND="
+ >=sys-auth/ykpers-1.14.0
+ >=sys-auth/libyubikey-1.6
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ dev-libs/glib:2
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( NEWS README )
+
+src_configure() {
+ eqmake4 YKPersonalization.pro
+}
+
+src_install() {
+ dobin build/release/yubikey-personalization-gui
+ doman resources/lin/yubikey-personalization-gui.1
+ domenu resources/lin/yubikey-personalization-gui.desktop
+ doicon resources/lin/yubikey-personalization-gui.xpm
+ doicon -s 128 resources/lin/yubikey-personalization-gui.png
+}