summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-08-12 07:17:06 -0500
committerBen Kohler <bkohler@gentoo.org>2022-08-12 07:20:27 -0500
commite302421ed29b0449bf862f26cc1108d38721e02a (patch)
tree01b228cda6ea58c219e415da45a227fe4315ec01 /sys-apps
parentsys-cluster/rdma-core: reassign inactive maintainer (diff)
downloadgentoo-e302421ed29b0449bf862f26cc1108d38721e02a.tar.gz
gentoo-e302421ed29b0449bf862f26cc1108d38721e02a.tar.bz2
gentoo-e302421ed29b0449bf862f26cc1108d38721e02a.zip
sys-apps/hwinfo: add 22.1
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hwinfo/Manifest1
-rw-r--r--sys-apps/hwinfo/hwinfo-22.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/hwinfo/Manifest b/sys-apps/hwinfo/Manifest
index e17ac8bdb782..ea61a3ee3c8c 100644
--- a/sys-apps/hwinfo/Manifest
+++ b/sys-apps/hwinfo/Manifest
@@ -2,3 +2,4 @@ DIST hwinfo-21.80-1.1.src.rpm 968192 BLAKE2B a11a1060137ff89504963c01c4129dcac93
DIST hwinfo-21.81-1.3.src.rpm 967951 BLAKE2B af6c390cd327ac2683f6b92a7847c5a0dc99e7553e35b7a5fd07db0a7f60c671a303e85061e1656474792b921e0d1b8ad18591f22a5da557879743d91151509a SHA512 eef89b5c8c029f606d66eb1740c4d046baaf490fc39d42d0137d1c4c5b248b0ddbe34b1532dbcef10f408677f173cfeb11d4c3e801a6a90280e1a6babc245674
DIST hwinfo-21.82-1.1.src.rpm 968922 BLAKE2B 5a491e7ca7125b40205dfa0e28350124f3deab6438424289ec44588940c47ddd341c9a7705edd3b9678b80050e26acdad1e9ea4aa7bc47e1af670ae020bfec51 SHA512 7221430e67bd76016d535db823e5e66034001c24e49de656365b421ef528bdcdf94ad82399f6a5916e55dc0b9f2dc1873a0e9ae2813025b746999bb2c5bd02df
DIST hwinfo-22.0-1.1.src.rpm 968737 BLAKE2B a4c252b97539ce97a4d56e543c08ea6804dc2678f47d6d60506913e6e26f3f797a61c1613d20d870ec4da7b48c400bb443e7a55ad374c2c0486e5c0d3dca9c7a SHA512 c53f1a1b1dcb9c7e07476a553c86663055853d0e1fffa1d5125b944e63d4f019e992c5ebf5cbbb2685428184bff569f5eb368172535dc2531b38f4d31180753d
+DIST hwinfo-22.1-1.1.src.rpm 969862 BLAKE2B f295c941804d3264b45739fa3d1801c2e31d67ce50f49caafeaae5a4dbf809fcfb9b44eaefee6ac9c61f54c1639fe1cf7ba710a9bbae5c4adbc7b5740e706796 SHA512 83f5d2dc78dfb10987a57a52f194d5db38ec66e73daad8fdf08386b131cf862b6c7bc3404451550f91363bb3d4090e67ca36aeba001f506075e55721004f2759
diff --git a/sys-apps/hwinfo/hwinfo-22.1.ebuild b/sys-apps/hwinfo/hwinfo-22.1.ebuild
new file mode 100644
index 000000000000..a54748333293
--- /dev/null
+++ b/sys-apps/hwinfo/hwinfo-22.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit rpm toolchain-funcs
+
+DESCRIPTION="Hardware detection tool used in SuSE Linux"
+HOMEPAGE="https://github.com/openSUSE/hwinfo/"
+#Using srpms from SUSE to get pregenerated changelog, otherwise we could use GH
+#SRC_URI="https://github.com/openSUSE/hwinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://download.opensuse.org/tumbleweed/repo/src-oss/src/${P}-1.1.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ amd64? ( dev-libs/libx86emu )
+ x86? ( dev-libs/libx86emu )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ >=sys-kernel/linux-headers-2.6.17"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ # Respect AR variable.
+ sed -i \
+ -e 's:ar r:$(AR) r:' \
+ src/{,isdn,ids,smp,hd}/Makefile || die
+
+ # Respect LDFLAGS.
+ sed -i -e 's:$(CC) $(CFLAGS):$(CC) $(LDFLAGS) $(CFLAGS):' src/ids/Makefile || die
+
+ # Respect MAKE variable. Skip forced -pipe and -g. Respect LDFLAGS.
+ sed -i \
+ -e 's:make:$(MAKE):' \
+ -e 's:-pipe -g::' \
+ -e 's:LDFLAGS.*=:LDFLAGS +=:' \
+ Makefile{,.common} || die
+ # Workaround from Arch, if using source tarballs from github
+ # echo 'touch changelog' > git2log
+ default
+}
+
+src_compile() {
+ tc-export AR
+ emake CC="$(tc-getCC)" RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ keepdir /var/lib/hardware/udi
+
+ dodoc changelog README*
+ docinto examples
+ dodoc doc/example*.c
+ doman doc/*.{1,8}
+}