summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/tuxonice-userui/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/tuxonice-userui/files')
-rw-r--r--sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch45
-rw-r--r--sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch88
-rw-r--r--sys-apps/tuxonice-userui/files/tuxonice-userui-1.1-freetype-2.5.patch38
3 files changed, 171 insertions, 0 deletions
diff --git a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
new file mode 100644
index 000000000000..8cc315f92082
--- /dev/null
+++ b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-Makefiles.patch
@@ -0,0 +1,45 @@
+diff -Nru tuxonice-userui-1.0.vanilla/Makefile tuxonice-userui-1.0/Makefile
+--- tuxonice-userui-1.0.vanilla/Makefile 2009-04-04 13:37:13.000000000 +0200
++++ tuxonice-userui-1.0/Makefile 2009-04-05 14:13:23.000000000 +0200
+@@ -32,15 +32,15 @@
+ all: $(TARGETS)
+
+ fbsplash:
+- make -C $@ all
++ $(MAKE) -C $@ all
+
+ usplash:
+- make -C $@ all
++ $(MAKE) -C $@ all
+
+ tuxoniceui_text: $(CORE_OBJECTS) userui_text.o
+ $(CC) $(LDFLAGS) -static $^ -o $@
+
+-tuxoniceui_fbsplash: fbsplash $(CORE_OBJECTS) fbsplash/userui_fbsplash.o
++tuxoniceui_fbsplash: fbsplash $(CORE_OBJECTS)
+ $(CC) $(LDFLAGS) -static $(CORE_OBJECTS) fbsplash/userui_fbsplash.o -o $@ $(FBSPLASH_LIBS)
+
+ tuxoniceui_usplash: usplash $(CORE_OBJECTS) usplash/userui_usplash.o
+@@ -48,8 +48,8 @@
+
+ clean:
+ $(RM) *.o $(TARGETS)
+- make -C fbsplash clean
+- make -C usplash clean
++ $(MAKE) -C fbsplash clean
++ $(MAKE) -C usplash clean
+
+ $(INSTDIR)/%: %
+ strip $<
+diff -Nru tuxonice-userui-1.0.vanilla/fbsplash/Makefile tuxonice-userui-1.0/fbsplash/Makefile
+--- tuxonice-userui-1.0.vanilla/fbsplash/Makefile 2009-04-04 13:37:13.000000000 +0200
++++ tuxonice-userui-1.0/fbsplash/Makefile 2009-04-05 14:14:53.000000000 +0200
+@@ -6,7 +6,7 @@
+ parse.o mng_callbacks.o mng_render.o render.o ttf.o
+ SOURCES = $(patsubst %.o,%.c,$(OBJECTS))
+
+-all: $(TARGET)
++all: $(TARGET) $(OBJECTS)
+
+ userui_fbsplash.o: $(OBJECTS)
+ $(CC) $(LDFLAGS) -r -nostdlib -nostartfiles $(SPLASH_LDLIBS) $^ -o $@
diff --git a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch
new file mode 100644
index 000000000000..bfe6d0a5e50e
--- /dev/null
+++ b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.0-libpng15.patch
@@ -0,0 +1,88 @@
+--- fbsplash/image.c
++++ fbsplash/image.c
+@@ -112,29 +112,29 @@
+ png_init_io(png_ptr, fp);
+ png_read_info(png_ptr, info_ptr);
+
+- if (cmap && info_ptr->color_type != PNG_COLOR_TYPE_PALETTE) {
++ if (cmap && png_get_color_type(png_ptr, info_ptr) != PNG_COLOR_TYPE_PALETTE) {
+ printerr("Could not read file %s. Not a palette-based image.\n", filename);
+ goto failed;
+ }
+
+- if (info_ptr->color_type == PNG_COLOR_TYPE_GRAY ||
+- info_ptr->color_type == PNG_COLOR_TYPE_GRAY_ALPHA)
++ if (png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_GRAY ||
++ png_get_color_type(png_ptr, info_ptr) == PNG_COLOR_TYPE_GRAY_ALPHA)
+ png_set_gray_to_rgb(png_ptr);
+
+- if (info_ptr->bit_depth == 16)
++ if (png_get_bit_depth(png_ptr, info_ptr) == 16)
+ png_set_strip_16(png_ptr);
+
+- if (!want_alpha && info_ptr->color_type & PNG_COLOR_MASK_ALPHA)
++ if (!want_alpha && png_get_color_type(png_ptr, info_ptr) & PNG_COLOR_MASK_ALPHA)
+ png_set_strip_alpha(png_ptr);
+
+ #ifndef TARGET_KERNEL
+- if (!(info_ptr->color_type & PNG_COLOR_MASK_ALPHA) & want_alpha) {
++ if (!(png_get_color_type(png_ptr, info_ptr) & PNG_COLOR_MASK_ALPHA) & want_alpha) {
+ png_set_add_alpha(png_ptr, 0xff, PNG_FILLER_AFTER);
+ }
+ #endif
+ png_read_update_info(png_ptr, info_ptr);
+
+- if (!cmap && info_ptr->color_type != PNG_COLOR_TYPE_RGB && info_ptr->color_type != PNG_COLOR_TYPE_RGBA) {
++ if (!cmap && png_get_color_type(png_ptr, info_ptr) != PNG_COLOR_TYPE_RGB && png_get_color_type(png_ptr, info_ptr) != PNG_COLOR_TYPE_RGBA) {
+ printerr("Could not read file %s. Not an RGB image.\n", filename);
+ goto failed;
+ }
+@@ -150,12 +150,12 @@
+
+ rowbytes = png_get_rowbytes(png_ptr, info_ptr);
+
+- if ((width && *width && info_ptr->width != *width) || (height && *height && info_ptr->height != *height)) {
++ if ((width && *width && png_get_image_width(png_ptr, info_ptr) != *width) || (height && *height && png_get_image_height(png_ptr, info_ptr) != *height)) {
+ printerr("Image size mismatch: %s.\n", filename);
+ goto failed;
+ } else {
+- *width = info_ptr->width;
+- *height = info_ptr->height;
++ *width = png_get_image_width(png_ptr, info_ptr);
++ *height = png_get_image_height(png_ptr, info_ptr);
+ }
+
+ *data = malloc(fb_var.xres * fb_var.yres * bytespp);
+@@ -171,11 +171,11 @@
+ goto failed;
+ }
+
+- for (i = 0; i < info_ptr->height; i++) {
++ for (i = 0; i < png_get_image_height(png_ptr, info_ptr); i++) {
+ if (cmap) {
+- row_pointer = *data + info_ptr->width * i;
++ row_pointer = *data + png_get_image_width(png_ptr, info_ptr) * i;
+ } else if (want_alpha) {
+- row_pointer = *data + info_ptr->width * i * 4;
++ row_pointer = *data + png_get_image_width(png_ptr, info_ptr) * i * 4;
+ } else {
+ row_pointer = buf;
+ }
+@@ -184,7 +184,7 @@
+
+ if (cmap) {
+ int h = 256 - cmap->len;
+- t = *data + info_ptr->width * i;
++ t = *data + png_get_image_width(png_ptr, info_ptr) * i;
+
+ if (h) {
+ /* Move the colors up by 'h' offset. This is used because fbcon
+@@ -196,7 +196,7 @@
+
+ /* We only need to convert the image if we the alpha channel is not required */
+ } else if (!want_alpha) {
+- truecolor2fb((truecolor*)buf, *data + info_ptr->width * bytespp * i, info_ptr->width, i, 0);
++ truecolor2fb((truecolor*)buf, *data + png_get_image_width(png_ptr, info_ptr) * bytespp * i, png_get_image_width(png_ptr, info_ptr), i, 0);
+ }
+ }
+
diff --git a/sys-apps/tuxonice-userui/files/tuxonice-userui-1.1-freetype-2.5.patch b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.1-freetype-2.5.patch
new file mode 100644
index 000000000000..f86f99a650fd
--- /dev/null
+++ b/sys-apps/tuxonice-userui/files/tuxonice-userui-1.1-freetype-2.5.patch
@@ -0,0 +1,38 @@
+From ed1b73cf2f073f39200be79c633deb292cb8d4af Mon Sep 17 00:00:00 2001
+From: Damjan Georgievski <gdamjan@gmail.com>
+Date: Mon, 6 Jan 2014 03:06:18 +0100
+Subject: [PATCH] fix #includes for recent freetype versions
+
+---
+ fbsplash/ttf.c | 3 +--
+ fbsplash/ttf.h | 3 +--
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/fbsplash/ttf.c b/fbsplash/ttf.c
+index 384f400..1dd841c 100644
+--- a/fbsplash/ttf.c
++++ b/fbsplash/ttf.c
+@@ -27,8 +27,7 @@
+ #include <assert.h>
+
+ #include <ft2build.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include FT_FREETYPE_H
+
+ #include "splash.h"
+
+diff --git a/fbsplash/ttf.h b/fbsplash/ttf.h
+index 034bb9e..6a4da9d 100644
+--- a/fbsplash/ttf.h
++++ b/fbsplash/ttf.h
+@@ -1,8 +1,7 @@
+ #ifndef _TTF_H
+ #define _TTF_H
+ #include <ft2build.h>
+-#include <freetype/ftoutln.h>
+-#include <freetype/ttnameid.h>
++#include FT_FREETYPE_H
+
+ #define CACHED_METRICS 0x10
+ #define CACHED_BITMAP 0x01