summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-11-11 13:36:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-11-11 13:37:29 +0100
commit90c029a4bc5d606355349f25a23d017a294028d7 (patch)
treede0a09f9cde841407b11f0e176bd30519299c058 /sys-apps/sg3_utils
parentapp-office/libreoffice: remove unused patch (diff)
downloadgentoo-90c029a4bc5d606355349f25a23d017a294028d7.tar.gz
gentoo-90c029a4bc5d606355349f25a23d017a294028d7.tar.bz2
gentoo-90c029a4bc5d606355349f25a23d017a294028d7.zip
sys-apps/sg3_utils: Bump to version 1.47
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/Manifest1
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.47.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/Manifest b/sys-apps/sg3_utils/Manifest
index cfa0aafc384b..39cbf40dd6fb 100644
--- a/sys-apps/sg3_utils/Manifest
+++ b/sys-apps/sg3_utils/Manifest
@@ -1 +1,2 @@
DIST sg3_utils-1.46.tar.xz 1031800 BLAKE2B 034af23d10da49938979ea4d0041c6ce4309b9ceac13f06bd524011dccf285e88fbc5f4c3f261ec3e316db86278ccff235015de43d98b0b62ff05a2f98df0850 SHA512 0b4caab97ccc11fb45e88219e460b37c6ff69b8f3c79e513279aef51783ff22399d141253abdbf55db198db0815bc39d30e9b1e3bd7dda5e15c5f4dae3fe89cf
+DIST sg3_utils-1.47.tar.xz 1046904 BLAKE2B 6efadd86f6d466469f5d5d3f53b2b6bf01143695db19e96b55a13a606d8a36d5571e390fed0b0990371dc4b77714f88c03f440a4468f6863544c0d21b2e3ef73 SHA512 ef072b8f0012d0944e21d2134aff7125e24ea24d1cbbb1aa79160e844f9a60236f1e244437a3bc08a22a7e99f613adad4a05ae5cc3916ded5a72d162cd3aa163
diff --git a/sys-apps/sg3_utils/sg3_utils-1.47.ebuild b/sys-apps/sg3_utils/sg3_utils-1.47.ebuild
new file mode 100644
index 000000000000..e0cea696ce63
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.47.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND="!sys-apps/rescan-scsi-bus"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED}/"${path}/libsgutils2{,-${PV}}.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}