summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-14 19:00:57 +0000
committerSam James <sam@gentoo.org>2021-06-14 22:11:13 +0000
commitdc8fb78b8b544c68940f26e4e61aacd9efdd1ad5 (patch)
tree2a5764ac7bd27646a2bf742881a333cc8ca64b98 /sci-physics/yoda/yoda-1.9.0.ebuild
parentdev-libs/xapian: fix build with GCC 11 in 1.4.17 (diff)
downloadgentoo-dc8fb78b8b544c68940f26e4e61aacd9efdd1ad5.tar.gz
gentoo-dc8fb78b8b544c68940f26e4e61aacd9efdd1ad5.tar.bz2
gentoo-dc8fb78b8b544c68940f26e4e61aacd9efdd1ad5.zip
sci-physics/yoda: add 1.9.0
Closes: https://bugs.gentoo.org/786909 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-physics/yoda/yoda-1.9.0.ebuild')
-rw-r--r--sci-physics/yoda/yoda-1.9.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-physics/yoda/yoda-1.9.0.ebuild b/sci-physics/yoda/yoda-1.9.0.ebuild
new file mode 100644
index 000000000000..eccb09af10af
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="root"
+
+RDEPEND="root? ( sci-physics/root:= )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P^^}"
+
+src_configure() {
+ econf \
+ --disable-pyext \
+ --disable-static \
+ $(use_enable root)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ default
+
+ newbashcomp "${ED}"/etc/bash_completion.d/yoda-completion yoda
+ rm "${ED}"/etc/bash_completion.d/yoda-completion || die
+}