summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2021-06-28 15:59:46 +0200
committerGuilherme Amadio <amadio@gentoo.org>2021-06-28 18:15:18 +0200
commit6612332362789e82e70209b83f9b682c8567f4e1 (patch)
tree1aa19d1c79d2a36ca4c4647c30f58fcabf428f5c /sci-physics/vgm
parentsci-physics/geant: move default C++ standard to C++17 (diff)
downloadgentoo-6612332362789e82e70209b83f9b682c8567f4e1.tar.gz
gentoo-6612332362789e82e70209b83f9b682c8567f4e1.tar.bz2
gentoo-6612332362789e82e70209b83f9b682c8567f4e1.zip
sci-physics/vgm: remove C++ USE flags, use C++17 as default
Geant4 11.0 and onwards will only support C++17 and above, so this is in preparation to remove C++ USE flags altogether in favor of coordinated settings in all packages that currently depend on such USE flags. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/vgm')
-rw-r--r--sci-physics/vgm/metadata.xml3
-rw-r--r--sci-physics/vgm/vgm-4.8-r1.ebuild (renamed from sci-physics/vgm/vgm-4.8.ebuild)8
-rw-r--r--sci-physics/vgm/vgm-4.9-r1.ebuild (renamed from sci-physics/vgm/vgm-4.9.ebuild)8
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild8
4 files changed, 9 insertions, 18 deletions
diff --git a/sci-physics/vgm/metadata.xml b/sci-physics/vgm/metadata.xml
index b5b1b3c1755c..70819ee2ad23 100644
--- a/sci-physics/vgm/metadata.xml
+++ b/sci-physics/vgm/metadata.xml
@@ -14,9 +14,6 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
- <flag name="c++11">Build using the C++11 standard</flag>
- <flag name="c++14">Build using the C++14 standard</flag>
- <flag name="c++17">Build using the C++17 standard</flag>
<flag name="geant4">Enable interaction with Geant4(<pkg>sci-physics/geant</pkg>:4)</flag>
<flag name="root">Enable interaction with ROOT (<pkg>sci-physics/root</pkg>)</flag>
</use>
diff --git a/sci-physics/vgm/vgm-4.8.ebuild b/sci-physics/vgm/vgm-4.8-r1.ebuild
index c99ae4840d23..db8bf0661fc6 100644
--- a/sci-physics/vgm/vgm-4.8.ebuild
+++ b/sci-physics/vgm/vgm-4.8-r1.ebuild
@@ -20,14 +20,12 @@ HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+c++11 c++14 c++17 doc examples +geant4 +root test"
-
-REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+IUSE="doc examples +geant4 +root test"
RDEPEND="
sci-physics/clhep:=
- geant4? ( >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?] )
- root? ( >=sci-physics/root-6.14:=[c++11?,c++14?,c++17?] )"
+ geant4? ( sci-physics/geant[c++17] )
+ root? ( sci-physics/root:=[c++17] )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? (
diff --git a/sci-physics/vgm/vgm-4.9.ebuild b/sci-physics/vgm/vgm-4.9-r1.ebuild
index ede9e854018d..1d116e9ae85d 100644
--- a/sci-physics/vgm/vgm-4.9.ebuild
+++ b/sci-physics/vgm/vgm-4.9-r1.ebuild
@@ -20,14 +20,12 @@ HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html https://github.com/vmc-projec
LICENSE="GPL-2"
SLOT="0"
-IUSE="+c++11 c++14 c++17 doc examples +geant4 +root test"
-
-REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+IUSE="doc examples +geant4 +root test"
RDEPEND="
sci-physics/clhep:=
- geant4? ( >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?] )
- root? ( >=sci-physics/root-6.14:=[c++11?,c++14?,c++17?] )"
+ geant4? ( sci-physics/geant[c++17] )
+ root? ( sci-physics/root:=[c++17] )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? (
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
index eb9ce1b27be0..fd992406f6e8 100644
--- a/sci-physics/vgm/vgm-9999.ebuild
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -20,14 +20,12 @@ HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html https://github.com/vmc-projec
LICENSE="GPL-2"
SLOT="0"
-IUSE="+c++11 c++14 c++17 doc examples +geant4 +root test"
-
-REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
+IUSE="doc examples +geant4 +root test"
RDEPEND="
sci-physics/clhep:=
- geant4? ( >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?] )
- root? ( >=sci-physics/root-6.14:=[c++11?,c++14?,c++17?] )"
+ geant4? ( sci-physics/geant[c++17] )
+ root? ( sci-physics/root:=[c++17] )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? (